Showing results for 
Show  only  | Search instead for 
Did you mean: 

Why does Firefox sometimes just not work with some sites?

Making moves

Firefox has been my default browser (Mac) for years, and it usually works well (except see this: Please mark minimized windows with a ♦ in the Window menu) 

But occasionally I find a website that works with other browsers, but not Firefox. The most common symptom is: I click on a button on the page, and…nothing happens. Copy the page URL into Safari and it works fine.

I haven't the faintest idea why this happens, but it seems to be happening more often lately. I wish it didn't.


Not applicable

Help up help you by providing proof of the issue.

Steps to replicate, screenshots, version mac, and version of Firefox. 🙄

Making moves

I have been trying to access the My Pillow website (which has worked previously) and keep getting the following message - 403 forbidden.  The same thing happens with Microsoft Edge, but not with Samsung Internet, which is the browser I use on my tablet.  Are Firefox and Edge engaging in censorship?  If so, I will find a different browser.

Making moves

Hi, I have experienced the same problem. For example with the 'One minute BBC News',

The page is shown but the video doesn't work. It works properly on Chromium.

I'm using Linux and my Firefox version is 102.3.0esr (64-bit)


Juan Manuel

Making moves

Jmm again, the same Linux system and the same Firefox version, 102.3.0esr (64-bit)

Just another example: I cannot load this link:

Chromium does it with no problem.

Regards, Juan Manuel

Not applicable

It works for me.  see the  lovely screenshot  ;-))

You need to show the issue.  Have you tried Firefox from Mozilla?

Making moves

Latest update to Firefox allows you to logon on to Amazon, but every page after the first is screwed up. Blog knows MS has been sending daily or more security updates as well so maybe they're at fault, but a friend using Chrome(yes, I know, friends don't let friends use Chrome) can access everything with no problem. So ...

Making moves

I am facing the same problem with my website. Here is its link I came here to see if I am the only person having the same issue or if someone else is facing the same problem.

Making moves

I am on Firefox 107.0 with Windows 10 22H1 and when I go to my banking web site, I can view the log in page, however, once I log in, nothing ever happens going forward. I refresh the page several times and then receive a message that the page is forbidden. I can use Microsoft Edge to log in and everything functions properly. The banking log in page is I had this same issue a couple of times when I was using Firefox 106.0, but do not recall exactly which version. Firefox was functioning properly during Firefox 106.0.5

Making moves

I agree and it seems to be getting worse by the day. It freezes a lot, and when I try to "move" emails, it doesn't work. Like you I have been a firefox user for many many years and I do hope that they fix this mess.

Making moves

I agree with everyone - especially the part that it is now worse then ever. The occasional glitch, fine I will switch to Chrome for that website, but it has just become intolerable. I have synced all my links over to chrome, set up the toolbar how I want it and now I am transferring all the passwords since Firefox can't seem to manage that. Sadly, I think this once great browser is in its final days.

Making moves

I have a similar problem.

I cannot logon to my account at the following site

I have to use Microsoft edge, or Chrome.

I've used Firefox as my default browser & prefer it.

Can this be fixed?

Mike D

Making moves

When I use Firefox with Empower Retirement or eTrade site and click on Statements, nothing shows but it works fine over at Edge.

Making moves

I have been experiencing the same issue with some sites. I select a button on the site and nothing happens. If I go to the same site with Edge, the site works.

What is happening with Firefox? I am using Firefox 111.0 (64-bit) on a Windows 11 machine.


Making moves

Same for me. In my case, it is with RBC Royal Bank in Canada. I have everything financial associated with them, even including estate management in the event I pass. The newest baby in the family is RBC Advisor, which is a portal to administer, for the user, a Defined Contribution Pension Plan initiated by my employer to this RBC service. I access thru my regular online banking methods just fine but, as I go thru steps of initiating my RBC Advisor, their systems hangs at some point, as if they are trying to fish something out of my Firefox browser that Firefox simply will not let them get to. Both my employer and RBC people told me I should just give up and get Google chrome. I despise all things Google to the highest level.

Making moves

I also cannot use some websites: for instance, I cannot interact with no links open, no images enlarge, no buttons are active if I hover over them, etc... I disabled AdBlock to no effect, but curiously, if I try to use the "pick element to block" when it is on, there are simply no elements to pick!