cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Yahoo comments not visible today

ithinktfiam
Making moves

Today, on Yahoo news, the button to go to comments still exists, but I click on it and it goes to a blank space. User comments are not populated. It still works fine on Edge.

Any clue if this is a problem with a Firefox update or coming from Yahoo?

1 ACCEPTED SOLUTION

jscher2000
Leader

Hi All, this could be a Tracking Protection block if Yahoo hosts its comments with a third party that does the same for multiple sites (the third party can engage in cross-site tracking). As a test, turn off Tracking Protection on Yahoo! News. Obviously not ideal because you'll probably see even more ads, but please test and see whether that allows comments to load. To do that, click the shield icon at the left end of the address bar (next to the lock) and click the slider switch to turn off tracking protection. Any difference?

View solution in original post

11 REPLIES 11

ChrisM1
Making moves

The same thing is happening to me today.

jscher2000
Leader

Hi All, this could be a Tracking Protection block if Yahoo hosts its comments with a third party that does the same for multiple sites (the third party can engage in cross-site tracking). As a test, turn off Tracking Protection on Yahoo! News. Obviously not ideal because you'll probably see even more ads, but please test and see whether that allows comments to load. To do that, click the shield icon at the left end of the address bar (next to the lock) and click the slider switch to turn off tracking protection. Any difference?

Yes, that worked. Thank you.

Thank you for testing that. You might be able to make a more precise exception just for the commenting site. This thread has an example of how people were setting that up for Disqus, but I don't know whether Yahoo uses Disqus:

https://old.reddit.com/r/firefox/comments/1cs30e1/openweb_discussion_not_displaying_in_firefox/

Wait! That only worked once. However, on the page it wouldn't let me enter a comment, "failed to publish." When I closed the browser and opened a new one, it shows the shield with a line across it, indicating protection is off, but the comments only show up half the time and I still can't post.

 

Any additional things to try?

 

I looked at a new story, and the comments are in a frame on this URL:

https://openweb.jac.yahoosandbox.com/2.0.0/safeframe.html

If I click "Log in" it takes me to a Yahoo! login page. So it seems I can't test without diving in more deeply than I have time for at the moment.

I guess Yahoo changes how they managed the pages. Thanks for that solution.

No comments loading for me

I have this same problem on Safari. However, I have recently found a workaround. If I get a "View Comments" link with no number for the comments, when I click on it, it just disappears. However, I find that if I go to the right of the screen, there is an ad with an 'X'. If I click on the 'X', it goes back to the previous screen. Now if I click on that same story, it loads with the comments accessible.  

mtlhd1955
Making moves

Yeah. Yahoo keeps changing their format. When they go back to the old style pages, everything works fine. Now they've gone to this 'New Look' and the Comments sections don't show up again. 

Luke1965
Making moves

Not sure what the problem is. It's only happening on my android tablet, not my android phone or my windows laptop. Things have been really weird this week, it's like AI has been given full control of everything and it's not doing that great a job.