Showing results for 
Show  only  | Search instead for 
Did you mean: 

Really S-L-O-W startup

Making moves

Firefox 98.0.2 in Linux...  from menu click to opening window takes 25 SECONDS!  No cpu activity and no network activity during that time.   What is Firefox doing?  Or, what is it waiting for?  On the same hardware, Debian firefox-esr 91.8.0 takes about 1 second; and the previous -Mozilla- version that I used, 97.0.1, also started up in about 1 second.   I think I should revert back to 97.0.1 and wait for this issue to be fixed.


Making moves

Maybe you are affected by this issue?

You could try to check IO e.g. with iotop.

Making moves

I have the same problem with firefox 100.0-1, downgrading to 97.0.2-1 solved the issue.

The issue appeared after I changed some settings : my os is EndeavourOS (Arch based) and it worked well, after switching to swaywm (Wayland, which implied to change the login manager to greetd with gtkgreet), firefox suddenly take 25-30s to start after the reboot (no problem when not rebooting) : whatever it does on the default wm, it solves the problem.

When I had experienced this problem on Ubuntu 22 (not noted the version of firefox), if before login to sway I logged to i3 (not even launching firefox), it permit to firefox to start correctly.

Making moves

I have the same problem with 100.0.2 (64-bit) on windows 7 with 16GB ram and i7 processor.

Firefox is so slooooow to start

Making moves

I've ended up profiling Firefox startup using windows Performance Monitor.
And the issue occurs while loading this huge directory (over 3 Gb) at startup :


Once cleared, Firefox starts instaneously again.