cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

"FirefoxCP Isolated Web Content" is slowly consuming all of my Mac's memory.

Ikram_Hasan
Making moves

Hello:

I use the M1 MacBook air which has 8 GB of RAM. I use it with a 4k 144Hz monitor.

I was searching for a browser that can take advantage of my 144Hz monitor and run smoothly. Safari works only 72 Hz and chrome initially runs at 144Hz but gradually it becomes choppy after using it for 10 minutes. 

Firefox is the only browser that can sustain the 144Hz and everything runs very smoothly.

But here is the problem I am facing with Firefox. After 30 to 40 minutes of use, my whole laptop froze. When I checked the Activity Monitor it shows that "FirefoxCP Isolated Web Content"  is taking 10+ Gbs of memory.

Then I closed Firefox, everything goes back to normal. Then I opened Firefox again and closed all the tabs and put my MacBook to sleep. When I opened my MacBook, the laptop is already struggling to do anything. There was no tap opened and even in the laptop sleep mode"FirefoxCP Isolated Web Content" is gradually taking 12+ Gbs of memory.

I really want to use Firefox. I have tried all the browsers and Firefox is the only one that can run smoothly on my 4k 144Hz monitor.

So I am requesting you to help me solve this issue.

Thank you.

55 REPLIES 55

seriochka
Making moves

Read through this... experiencing the same thing on my 2012 Macbook Pro with 16GB of RAM. When I killed the offending CP process, it crashed my LinkedIn Tab only (https://www.linkedin.com/feed/). Lots in this typically and different types of content, but yeah...

 

baldfury1
Making moves

using activity monitor, click on the firefoxCP isolated web content hogging memory and then the x. the offending tab in my case was hootsuite. told me "Gah. Your tab just crashed." It's not firefox but what is in the open tabs......

" It's not firefox but what is in the open tabs"--Not in my case!  Even when I close all tabs but two belonging to blogs I like, which never used to cause any problems, it is still sucking up incredible amounts of memory.

We [OK, I] really need someone with authority at Mozilla to chime in here and say, "We are working on it and will have this handled for you, in a new update, before the month it out."

"Connect Community" is swell, but it should not take the place of concerted action on the part of Mozilla to take care of a longtime user concern.

RedRockRick
Making moves

I came to this thread because I was looking at my activity monitor and saw that there were 13 instances of "FirefoxCP Isolated Web Content" open.  I have a Mac Studio with 128 GB of Memory and the Apple M1 Ultra Chip. I also have the Apple Studio Display and 2 additional 27 in Samsung monitors. 

Currently I have 10 tabs open and Firefox is using about 7.5 GB of memory.  I was shocked.  I also have Safari open with 13 tabs and it is only consuming less than 1 GB of memory.  I am not having any issues like you describe but it seems to me that you should not have the issues with Safari that you are having.  Could this be a graphics card issue? 

RobotSausage
Making moves

I just had this same issue. After reading some of the replies here, I realized I had TWO Firefox tabs open with two different Amazon products I was keeping an eye on. I closed those two tabs and the CPU fan of the 2017 MBP almost instantly started to calm down and the machine resumed its usually snappy response times.

Alexander-Wilms
Making moves

Same issue here. Firefox Isolated Webcontent process took up 8 GB of RAM:

https://www.welt.de/vermischtes/article243942169/Patricia-Schlesinger-klagt-auf-Ruhegeld-Ex-Intendan...

Firefox 109.0.1 (64-Bit)

Operating System: openSUSE Tumbleweed 20230222
KDE Plasma Version: 5.27.0
KDE Frameworks Version: 5.103.0
Qt Version: 5.15.8
Kernel Version: 6.1.12-1-default (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-7700K CPU @ 4.20GHz
Memory: 15.6 GiB of RAM
Monitor: Dell Inc. S2721DGF running at 144 Hz

BaBa2023
Making moves

Same here. It immobizlsed  my new mac and my new macbook pro, both with Ventura 13.2.1.

I used to love mozilla. But I'm switching to chrome. Trouble not worth it. Thanks for the tips

FirefoxCPUwtf
Making moves

same issue regardless of operating system. FirefoxCP Isolated Web Content is using 100% CPU. It must have something to do with cross-site cookies being blocked. Either a mozilla oversight or websites trying REALLY hard to see cookies in your other sites

phr
Making moves

Well, a single tab could easily consume 1 GB of RAM.

Trying using Google Maps for some time - zoom in/out, switch to Map/Sattelite/StreetView etc.

But it's the same in e.g. Chrome

bulgroz06
Making moves

I have the same issue on Ubuntu and Firefox. The Isolated Web Content process appears each time I log into my bank account and disappears when I log out or delete the tab. The %CPU starts with 400% then stabilizes at 100% causing my fan to accelerate very strongly. Surprisingly this does not happen with the Brave navigator.

akonit
Making moves

I opened `about:processes` in Firefox and fond out that opened windows (tab) consumes an lot of energy, and this was simple (VisualStudio site)[https://code.visualstudio.com/updates/v1_80] so I just closed this tab and FirefoxCP Isolated Web Content resumed to consume normal amount of energy.

akonit
Making moves

I opened `about:processes` in Firefox and fond out that opened windows (tab) consumes an lot of energy, and this was simple (VisualStudio site)[https://code.visualstudio.com/updates/v1_80] so I just closed this tab and FirefoxCP Isolated Web Content resumed to consume normal amount of energy.

Abikitty
Making moves

Nothing has worked for me, including getting rid of most extensions, including Ad Block.  I'm angry and also feeling very sad because I have been using FireFox almost from its beginning and loved it.  I love the many beautiful themes people have made for it and many of its extensions, but it has reached the point where I have to waste a great deal of time even just trying to close it.  Hitting the "X" over and over, and using ESC can still freeze things for an indefinite time, and Microsoft Word has become abysmally slow.  Typing an email gets terribly slowed down after a while, every time, unless it's quite short.  The problems went away after I decided to give up on FF and (in the last few days) switched to Chrome.  I don't like it as much as FF, but at this point, I can't do my job using FF, and it is just too much to handle.   Once in a while, I open FF for some brief task.                                                                                                                                                                        Recently, I found a long list of suggestions from Mozilla as to how users can try to fix the problems.  It should not be up to the users to spend hours trying this and that, while waiting 1, 5, 10 minutes --or who knows how long it will be-- at each juncture because FF keeps freezing.  Years ago, with one of the early less stable versions of Windows, I once got rid of a whole PC for behavior like that, though it meant buying a new one, so why keep putting up with it in a browser?  If Mozilla gives up on what seems to be a mad experiment and lack of respect for its users, there is a chance I will come back.  But for now, I am learning how to use Chrome and have made it the default. 

By the way, long ago, I once tried refreshing/resetting FireFox to solve another problem, and only succeeded in losing all my bookmarks, so once bit, twice shy, so far as trying that solution goes!

Infinity-AX
Making moves

I also have the same issue on my MSI Katana laptop running Linux Mint. This could be a memory management bug, as I experience similar symptoms when I accidentally forget to release the memory in my C programs. My remedy for this issue is to check and see which tabs are responding or working correctly and close the ones that are not. Tabs that are not responding or working are usually the ones hogging the resources. Your solution to close the browser, wait a few moments, and reopen it is also valid. I would also suggest closing any tabs you are not using and closing the browser completely when not using it. You can also try removing any extensions you don't need and update the browser and extensions.

▐ Dr. AX ▌

Mizar
Familiar face

You could try setting at about:config

dom.ipc.processCount.webIsolated to 0

dom.ipc.processPrelaunch.fission.number 0

fission.webContentIsolationStrategy to 0

and

browser.tabs.remote.separatePrivilegedMozillaWebContentProcess to false