Showing results for 
Show  only  | Search instead for 
Did you mean: 

Where is "Open With"??????!!!!!!

Making moves

It is the worst browser change. "Open with" was the reason why I preferred Firefox over Chrome and others. You need to return that configuration to how it was before. AWFUL!!!!



As you noticed, Firefox 98 changed the default from "Always Ask" to "Save File". If the problem is with a content type you download regularly, you usually can change back using one of the following methods:

(A) Select Always Ask on the Applications list

Steps here: 

(B) If the content type is not on the list, try this

On the Downloads list, right-click the download and look for "Always Open Similar Files". Clicking that will add a new action to the Applications list which you can change from "Use [relevant application]" to "Always Ask"

(C) If "Always Open Similar Files" isn't available, it typically indicates that the server didn't provide a specific content type for the file, just a generic binary file content type.

This is harder to work around but I can suggest an option if needed.

Making moves

Restore download prompt in Firefox 98

1. Enter "about:config" in the address bar.

2. Click “Accept the risk and continue”.

3. Type "panel" in the search bar, wait for results to be displayed.

4. Go to

5. Toggle its value to false.


Keep in mind that will be removed once the feature is debugged (as we have all experienced with other temporary preferences). Keep reporting problems because if you wait until that is removed, it may be too late to get the changes you want.

Now the question is, how much complaint do we need until Mozilla stop trusting their unreliable telemetry and listen to users' voice instead?