Showing results for 
Show  only  | Search instead for 
Did you mean: 

Thunderbird CPU hog

Making moves

I quit using T-bird a couple of months ago and started using Evolution (and RE-using Vivaldi's email function in its browser) because Thunderbird would get into a lengthy, unexplained, CPU chewing meltdown that would start to overheat my poor ol' Linux laptop.

When I saw hints that Thunderbird 102+ was great, had improvements and bug fixes, I upgraded to 102.4.0 (64-bit). Sadly, that didn't last long. It's back to its old tricks. Really, folks?

Gonna have to shut it down soon, or it will shut itself (and the whole system) down when it gets too hot.


Making moves

Just in case this is useful:

My Thunderbird was getting slower and slower in one of my Linux computers, draining the CPU to 100% in a powerful i7 until it got unusable. I've been using TB for years happily, copying the TB profile folder from one computer to another after each new installation.

Solution (for me) in Linux:

  • Rename the profile folder, e.g., a9b8tfg.default to, e.g. a9b8tfg.default.old or save it to a known location.
  • Create an empty folder with the previous name, e.g., a9b8tfg.default (or make a fresh TB installation and forget the renaming).
  • Start TB and choose Tools/Import from the old profile folder (e.g., a9b8tfg.default.old).
  • Once imported, restart TB and set-up the user/passwd in your e-mail accounts.

I bet I had a lot of old configurations mixed in my TB profile that started to conflict since years reusing it combined with TB updates. Now it is running smoothly again, operating several mail accounts, a TB calendar and a lot of folders and archived folders.

Thanks, Ramon. It worked! -- For about one day. Sigh. It's back to its constant minimum of 55% CPU and 16% memory -- both way more than anything else I have and NOTHING seemingly going on in the app. Just sitting there churning. Going back to my less-than-satisfactory Vivaldi browser mail setup for now, but really appreciate the suggestion!!!!

Here's an example of what top shows: 

192429 xxx 37 0 4603428 1.2g 98172 S 53.8 15.1 310:12.82 thunderbird-bin

That's 53.8% CPU and 15.1% memory essentially just idling. Not fetching, indexing, or doing much of anything!

Hi Ramon, check out my last post (previous to this reply). Thanks for responding originally. Thought I'd pay you back with this tidbit.

Making moves

Wellsir, it doth appear that this issue has been "out there" for 10 years or more, and the solution was posted in this forum: . I can't believe that the developers and maintainers have left this setting untouched and "in error" (?) all this time. Needless to say, just appending the one zero seems to have done the trick. Hopefully, this is the end to CPU temp shutdowns!

Shoulda taken "Wayne's" advice in the rainbow chard thread posted above, being that he's a T-bird dev. He's right, that setting doesn't really solve the problem. I've had to just click the online/offline toggle at the bottom left of T-bird so it doesn't try to do whatever it keeps on trying to do, until I want to check my mail again. If I don't, I run the risk of temperature shutdowns in my Linux system. This sucketh.