Showing results for 
Show  only  | Search instead for 
Did you mean: 

Thunderbird 115.2.2 just freezes after running few hours -its Not Stable as the ealier verisons

Making moves

Upgraded from Thunderbird 102.7.2 - 64bit on Windows to 115.2.2 and this version is the worst, unstable version. After running for few hrs,  it freezes  (spinning wheel) - and I have to kill it and restart after waiting 30 seconds. I don't if there is a way to share logs, if so please advise, which and where the logs would be so I can file a Bugzilla report.



Making moves

I have the same experience. It was updated without aprovall and start problems. I have a feeling that it freezes after a certain amount of time. I'm not sure if turning off the monitor after a certain period affects it or if it freezes on its own. (115.3.1)

Making moves

Same here.

Everything was working fine untill I restarted Thunderbird, and it got updated from 102 (I'm not sure of the exact version) to 115.

Now I can't even change folders without the program freezing for a mintue  or so. My profile is somewhat big (18-19 GB) and I have 4 add-ons: @Contact Mention - Grammar & Spell Checker - mailmindr - Send Later.

Restarting the program in compatibility mode, so the addons are disabled, seem to fix it, but it still takes about two to three seconds to change folders. Again, it worked perfectly fine on 102 with everything enabled.

Got a downgrade and it seems to work, but I can't troubleshoot any longer. I have work to do.

The downgrade is not linear, as Thunderbird doesn't allow you to open your now "upgraded" profile. I'll leave the procedure for anyone that may want to do it, untill Mozilla fixes this issue, so you don't have to search it again:

  1. Get the previous version of Thunderbird from Directory Listing: /pub/thunderbird/releases/ (
    I used this one Directory Listing: /pub/thunderbird/releases/102.15.1/win64/ ( but it was kind of random. I just wanted to roll back to 102.
  2. Run the .exe, make sure to select the same folder where you have Thunderbird installed, and it will prompt you to "Upgrade" instead of "Install".
  3. Don't launch the program once it's done. Press Win+R and write the following in the window: thunderbird --allow-downgrade
  4. (Optional) Go to settings and change updates to "Check for updates, but let me choose wheter to install them" so you don't get the latest version when you restart the program.

That should give you a quick fix.

It seems, for me helped this 2 things (I do not know, which one it was but I want not try it more):
- restart Thunderbird into compatibility mode

- disable display default Thunderbird's home page

- restart back to standard mode

Now it seems, all works. May be, it was homepage ...

Making moves

t seems, it worked one day only ... 😞

Making moves

Is anyone from the development team reading this? Even version 115.3.2 (64bit) didn't fix the email freezing issue.

Making moves

What helped me - downgrade to last non Supernova version




Making moves

Same with 115.3.2.  I now close the program after checking email to avoid the freeze.  Annoying.

Making moves


 just wanted to let the community (and thunderbird dev) know that I had a solution (for my particular situation).

115.4.2 (64-bit)   Win 8.1

I was coping with this problem a full month now killing and restarting over and over. I read somewhere in one of the 115 freeze threads that it might be caused by a cache problem.  So I started to inspect the logs and generated json files, in folderCache.json I found a couple of issues.

1.  All former Blogs and Newsfeeds are in this file (also some that I dismissed long time ago > 10 years )

2. There was one newsfeed started again i.e. the disabled check was still on but the newsfeed was enabled, so I assume this default setting is somehow changed by the update to 115.

I removed all old and the running newsfeed structures from folderCache.json and started Thunderbird.

Thunderbird is running smooth and more responsive now for more than a day!

Maybe some connect loop or nonexisting cache paths, which stalls the UI?

Have fun, kind regards, Fekke


Making moves

For me it freeze under W10 and newly under W11 still (115.5.1). I found in "crashes" this:

mozLz40 8 ô{"v":1,"crashes":{},"countsByDay đrruptDate":null}

Tried export , remove Thunderbird, install new and import ... omg, this export does not save passwords ... Fortunately, I had backuped profil.

Making moves

Still in "not responding" state once in a while, I attached the debugger, seems to be the xul message loop

[External Code] Annotated Frame
> xul.dll!mozilla::widget::WinUtils::WaitForMessage(unsigned long aTimeoutMs) Line 471 C++ Symbols loaded.
xul.dll!base::MessagePumpForUI::WaitForWork() Line 253 C++ Symbols loaded.
xul.dll!base::MessagePumpForUI::DoRunLoop() Line 224 C++ Symbols loaded.
[Inline Frame] xul.dll!base::MessagePumpWin::RunWithDispatcher(base::MessagePump::Delegate * delegate, base::MessagePumpWin::Dispatcher * dispatcher) Line 59 C++ Symbols loaded.
xul.dll!base::MessagePumpWin::Run(base::MessagePump::Delegate * delegate) Line 79 C++ Symbols loaded.
[Inline Frame] xul.dll!MessageLoop::RunInternal() Line 368 C++ Symbols loaded.
xul.dll!MessageLoop::RunHandler() Line 362 C++ Symbols loaded.
[Inline Frame] xul.dll!MessageLoop::Run() Line 343 C++ Symbols loaded.
xul.dll!base::Thread::ThreadMain() Line 187 C++ Symbols loaded.
xul.dll!`anonymous namespace'::ThreadFunc(void * closure) Line 20 C++ Symbols loaded.
[External Code] Annotated Frame
mozglue.dll!00007ffa1adea485() Unknown No symbols loaded.
[External Code] Annotated Frame

Start and break always lands in the above threa.

I can step out till:
[Inline Frame] xul.dll!base::MessagePumpWin::RunWithDispatcher(base::MessagePump::Delegate * delegate, base::MessagePumpWin::Dispatcher * dispatcher) Line 59 C++ Symbols loaded.
The locals at this stage are:

Maybe the handling of should_quit is incorrect:
- this 0x0000008041b1c830 {message_hwnd_=0x00000000001802bc {...} } base::MessagePumpWin * {base::MessagePumpForUI}
+ [base::MessagePumpForUI] {message_hwnd_=0x00000000001802bc {...} } base::MessagePumpForUI
+ base::MessagePump {mRefCnt={mValue={...} } } base::MessagePump
+ observers_ {observers_={ size=0 } notify_depth_=0 type_=NOTIFY_ALL (0) } base::ObserverList<base::MessagePumpWin::Observer,0>
+ delayed_work_time_ {ticks_=0 } base::TimeTicks
have_work_ 0 long
+ state_ 0x0000008055a2f648 {delegate=0x0000008055a2f718 {type_=TYPE_UI (1) id_=19 work_queue_={ size=0 } ...} ...} base::MessagePumpWin::RunState *
delegate Variable is optimized away and not available.
dispatcher Variable is optimized away and not available.
+ previous_state 0x0000000000000000 <NULL> base::MessagePumpWin::RunState *
- s {delegate=0x0000008055a2f718 {type_=TYPE_UI (1) id_=19 work_queue_={ size=0 } ...} dispatcher=0x0000000000000000 <NULL> ...} base::MessagePumpWin::RunState
- delegate 0x0000008055a2f718 {type_=TYPE_UI (1) id_=19 work_queue_={ size=0 } ...} base::MessagePump::Delegate * {MessageLoop}
+ [MessageLoop] {type_=TYPE_UI (1) id_=19 work_queue_={ size=0 } ...} MessageLoop
- __vfptr 0x00007ffa02ee12a0 {xul.dll!const MessageLoop::`vftable'} {0x00007ff9fd2669c0 {xul.dll!MessageLoopForUI::~MessageLoopForUI(void)}, ...} void * *
[0] 0x00007ff9fd2669c0 {xul.dll!MessageLoopForUI::~MessageLoopForUI(void)} void *
[1] 0x00007ff9fd8643b0 {xul.dll!MessageLoop::DoWork(void)} void *
[2] 0x00007ff9fd8645d0 {xul.dll!MessageLoop::DoDelayedWork(base::TimeTicks *)} void *
[3] 0x00007ff9fd8646d0 {xul.dll!MessageLoop::DoIdleWork(void)} void *
dispatcher 0x0000000000000000 <NULL> base::MessagePumpWin::Dispatcher *
should_quit false bool
run_depth 1 int


unfortunately no sources, if I have some spare time in the future I will get the sources and debug properly.