cancel
Showing results for 
Search instead for 
Did you mean: 

Scrollbars disappear in Firefox 100

Neon5
Making moves

(Firefox 100.0 64-bit on Windows 11)

Hi!

Since updating to Firefox 100, scroll bars disappear on web pages if I don't move the mouse for three seconds. Is there any way to make them permanently visible again?

I need visible scrollbars in the main web application that I use for work, to keep an overview about the displayed information. Invisible scrollbars are a desaster. And it's inconsistent with all the other Windows applications that constantly show scrollbars. Also it may be an accessibility issue for visually impaired people.

Besides of that, I perceive any ongoing animations like the delayed outfading of the scrollbars as distracting and annoying. Have multiple scrollable panels on the screen, move the mouse pointer and my attention to the panel on the left and - whoops - something is happening to the right. :-S There already is a setting in the Firefox preferences to disable smooth scrolling; would be helpful if the scollbar animation could be disabled in a similar way.

Thanks for any help to fix this.

Peter

13 REPLIES 13

Neon5
Making moves

Ok, this is Windows-11-related. Looks like Firefox 100 was changed to adopt some native Windows 11 scrollbar behaviour. There is a Windows 11 accessibility setting "Always show scrollbars", which was disabled. Enabling brings back the old steady fat scrollbars in Firefox. That will be fine for me.

Interestingly, Microsoft's Edge browser ignores that Windows setting and never hides scrollbars on web pages.

 

jimfoye
Making moves

I'm seeing this on Linux. It's very annoying. Is the goal to eventually get rid of the vertical scrollbar altogether? What can I do to fix this?

According to the Firefox 100 release notes, there is some new Firefox setting on Linux to restore the old scrollbars.

Found it, thanks! I just went to Settings on the Firefox menu, and searched for "scrollbar", and there is a checkbox, "Always show scrollbar".

Dee_veloper
Making moves

"On Windows, Firefox follows the system preference (System Preferences > Accessibility > Visual Effects > Always show scrollbars)."

There is no such thing as "Accessibility" on either windows 10 or Firefox settings.
===============================
To access the scrollbar setting in Windows 10, you have to click on the Start button and then the gear-like symbol to open the Settings app.

Next choose Ease of Access from the options.

Among the tabs on the left-hand side, select Display.

Under "Simplify and personalize Windows," find the Automatically hide scrollbar in Windows toggle switch and switch it to Off/On.


@Dee_veloper wrote:

"On Windows, Firefox follows the system preference (System Preferences > Accessibility > Visual Effects > Always show scrollbars)."

There is no such thing as "Accessibility" on either windows 10 or Firefox settings.
===============================
To access the scrollbar setting in Windows 10, you have to click on the Start button and then the gear-like symbol to open the Settings app.

Next choose Ease of Access from the options.

Among the tabs on the left-hand side, select Display.

Under "Simplify and personalize Windows," find the Automatically hide scrollbar in Windows toggle switch and switch it to Off/On.


Did your scroll bars change on Windows 10, too? I thought this was a Windows 11 feature.

Hi jscher2000,

we discovered this change as well. We normally hide the scrollbar, but with Firefox 100 (Ubuntu and Windows) the scrollbar is shown again. With the system setting we can get the old behavior again. But we can't reach out to our customers to do this. Is there a possibility to disable this on our WebApp?

Cheers Thomas

Roxxsmom
Making moves

Same here, and sometimes the scroll bar doesn't reliably appear, or it is very hard to click on and drag, even when I mouse over where it should be. It's like it disappears or is partially pushed off the right side of the screen.

I am running windows 11 64 bit, and my computer specs are:

Intel core i7-8700 CPU, 32.0 GB of RAM, and my video card is an NVIDIA GeForce 1070Ti. This has made it particularly hard to work with Canvas, which I must use to teach my classes at the college where I work. This app requires a lot of scrolling, so the missing scroll bars are a real chore.

 

vm
Making moves

I noticed after upgrading my Linux computers that I could no longer scoll the right side (dock section) of the TD Ameritrade web site. It took me a week to figure out what was causing it. Clicking "Always show scrollbars" in the firefox settings solved it. It was weird that the dock side wouldn't scroll no matter how I tried to scroll, mouse wheel, touchpad, clicking on the scrollbars directly, nothing worked.

Goshmir
Making moves

I am using a Mac, but same problem here. It strikes me that the scrollbar disappears because it seems that if the website has a cookie statement pop up, which is not visible. I know that because in another browser I do get the cookie pop. And no, I do not block pop ups in Firefox.

Other similar hiccups are that on certain websites the login button is greyed-out. And after reasearch I foudn oud that is has something to do with Google recaptcha security, which the website uses.


@Goshmir wrote:

I am using a Mac, but same problem here. It strikes me that the scrollbar disappears because it seems that if the website has a cookie statement pop up, which is not visible. I know that because in another browser I do get the cookie pop. And no, I do not block pop ups in Firefox.


This problem can be caused by add-ons that remove ads and cookie notices -- while they may remove the content and/or the overlay, they might not have the ability to reverse the scrolling restriction.


Other similar hiccups are that on certain websites the login button is greyed-out. And after reasearch I foudn oud that is has something to do with Google recaptcha security, which the website uses.


Hmm, Google reCAPTCHA works for me on the sites I use. Perhaps one of your privacy or container add-ons is interfering.

chelovechek48
Making moves

Firefox has a function to automatically hide the scrollbar.
A lot of people try to delete it, but I like it.
I used this on Linux, but I don't have it on Windows.

Version 101.0.1 (64-bit)

firefox.jpgwindows.jpg