Showing results for 
Show  only  | Search instead for 
Did you mean: 

Mozilla Thunderbird issues with Outlook Accounts

Familiar face

I'm not really sure if this is the right place to have this addressed but i'm having issues with Outlook email accounts in Mozilla Thunderbird.

Apparently is keeps on asking for the password even though it has been memorized.

The version number is

115.7.0 (64-bit)


I was blocked untill I removed the other outgoing server as you mentioned.


I had a scarey email from Microsoft saying they were making  OAuth2 Compulsory from September this year.

No OAuth2, no email!

I wonder why, as I am already set up with it, so why send me a scary email???

Making moves

This is the best we can hope to do here?  To just say "same" with no fix from Mozilla?  Well, at least we now all know that it's not an isolated situation.  This happened to me about a week ago and, just prior to the 115.7 update.  I then applied the 115.7 update thinking the fix was in that version.  It wasn't.  For me, as with so many others here, this continues and, at times, blocks me from access to my email accounts after about 6 tries of me putting in the already saved password in the box.  Other times, it does go through after many "retry" attempts and entering the password manually again and again.

To be fair, you've got to give TBird devs time to catch up with whatever changes Microsoft and other email providers make. TBird is a free product after all. Many of the people working on it may be volunteers.

For a personal (not a work/school) account, these settings are working for me on Windows 11 using version 115.7.0 (64-bit):

In Account Settings/<account name>/Outgoing Server (SMTP) (bottom of page)

Outgoing Server (SMTP): [choice shown is labeled:] " (Micorosoft) -"
(the label isn't necessarily important, the settings you see if you hit "Edit SMTP server..." are what matters)
Hit "Edit SMTP server" to see and/or edit values

Description: <whatever you or TBird called it>
Server Name:
Port: 587
User Name: <your email address>
Authentication method: OAuth2
Connection Security: STARTTLS

In Account Settings/<account name>/Server Settings

Server type: IMAP Mail Server
Server name: Port:993
User Name: <your email address>
Security Settings:
Connection security: SSL/TLS
Authentication method: OAuth2

Also, in Account Settings/Outgoing Server (SMTP), there's a table of all the SMTP servers. Make sure there's only one for I had found two, one of which still had 'normal password' for authentication method, which I didn't want any longer, since I only want to use OAuth2 for this email account.

Note that after changing the settings you probably have to restart TBird for them to take effect.

If you have these settings, and it still doesnt work, try adding cookie exceptions (I'm not entirely sure this is necessary, but it shouldn't hurt):
Open Settings/Privacy & Security/Web Content/Exceptions
Add an exception to Allow "" if its not already there.

If it still doesn't work, you could try letting TBirds new account Wizard re-add your email account.
I myself did the following:

  1. Since all my emails are on the server, I removed my existing email account from TBird. Removing the account also removes any TBird customizations that were made for that account (for example "Message Filters"), so I made notes of anything like that which I wanted to restore later.

    IMPORTANT - I'm not a TBird expert, just another user, so I certainly can't guarantee that something important might not be lost if/when an account is removed from TBird. I didn't lose anything, but other people's setup might be very different than mine. Only do this if you accept full responsibility for any and all possible consequences.

    (Actually, I don't know enough about how TBird works, but possibly you could just add your email account in a second time without first removing the original instance. )

    If you decide to remove your account, the 'remove account' button is found on the Account Settings page. Select the account, then hit the 'Account Actions' drop down near the bottom of the page.

  2. I added the email acount back into TBird, using the Wizard.
    *   Menu/New Account/Existing Email
    *   Filled in name/email/password and checked the remember password box, then hit continue. It came back saying "Cofiguration found in Mozilla database", and had the IMAP pane selected with values matching those shown above. You can't see it at this point, but that default config is using "normal password", and I want OAuth. (so don't hit Done yet.)
    *   Hit 'Configure Manually', then changed the Authentication Method for both the IMAP and SMTP server to "OAuth2". Then hit Done.
    *   At this point I believe I got the normal oauth web dialog pop up where you log in to your Outlook account, and everything worked fine from then on.

Your suggestions, plus my password change, have worked for the time being.  The server change and the STARTTLS appear to work.  Now let's see if it gets confused with my work email which was happening earlier,since one is Hotmail and the other is an outlook address for my employer.  Earlier, when I changed my Hotmail, it was asking me for my work credentials to send email from that rather than from my hotmail account.  I checked, and the email addresses were correct in the SMTP.

Thank you for your very detailed instructions. I changed the server in "Edit SMTP Server" to "" as, it was originally set as "".
There was no "OAuth2" as an authentication method in "SMTP server" options. Then, in server settings, I changed the server name there too to "". I did set the Authentication to Oauth2 in Server settings but, (as has happened to me before) another window popped up from microsoft asking for a password but, when I put in the password in there, it said "sign in was blocked" so, back to "normal" authentication.

Also, before I found THIS thread, I had been searching online for about a week and found other threads that went back a couple of years concerning people having this same problem. This was one of the troubleshooting tips I did from one of those websites...I removed all saved passwords, rebooted the program and even my computer and then, I re entered each one manually checking the option to save them again but that didn't help.
Anyhow, I have multiple email addresses in Tbird so, I'll see if changing the server on one of them will improve things.

Thanks again for the time you spent posting all that information.

Note that the address I used (still working I hope) is and a default port of 143. 

The only thing I know I didn't tell you is that I had my webmail open to hotmail at the time I was fiddling with this.  Sometimes if you are getting hit with hackers (about a dozen today) they want you to change the password,and I had to do that when I tried to log in.  Also, the OAuth2 is available if you go to STARTTLS login on your connection security settings.

As i said, send is not working right now for Hotmail since TBird won't let me have two office365 sending addresses.  I might have to mess with identities if I get desperate.

I wish you luck.  See RickK below for even better settings, etc.

Thank you Russ.  Well, at least I can send email.  I just tested it after reading your post.  I had to sign in again but, anyhow...

I also clicked the link that was posted here and read some of the Microsoft article where they acknowledge problems with apps signing into Outlook at this time so, hopefully they get to fixing that.

Making moves

Same problem here.

Making moves

s anyone working on the problem

Making moves

I have an office 365 account, not free. It's working very well.

Outgoing Server (SMTP): Microsoft - (default) Port 587
Connection Security (SMTP): STARTTLS
Authentification (SMTP): OAuth2


Server Name: port 993
Connection Security: SSL/TLS
Authentification: OAuth2

Making moves

I have this problem with the Hotmail account. I have reset the password to verify it was not a forgotten problem, have logged into webmail with no problem, and have checked the imap settings on the Thunderbird help site.  I am not using two-factor authentication either, so that issue should not be present.  Are you sure your server settings are right?

Russ Smith


My work address uses a microsoft365 account, and I have put in separate credentials for both, but every time I try to send a work email I wind up it tries to send from my hotmail account.

I have also

Thanks.  Yeah, I just changed them to "" as per RichK's recommendations.  I'll have to give it some time to see if it works.

Making moves

In my case with 'Hotmail,' as was previously mentioned, I went to Tools> Options> Security> Saved Passwords' and deleted the passwords for Hotmail. Closed and reopened T'bird, and when asked, re-entered relieve/send password. It seems to have resolved the issue. at least temporarily.. or it is a coincidence and MS/Outlook fixed it on their end. I have closed and opened T'bird a few times, and is seems to be normal again.

Making moves

All righty then. As one of the fellow users of Tbird posted here, turns out, it was a problem Microsoft had to fix.  I assume they fixed it as, I haven't been asked for a password in 2 days.  Great.  Thanks to all the fellow users of Tbird for your input. 

Making moves

Since updating to this version I first had an issue with outlook mail and had to change the password security from normal to OAuth2. Today I went in and it kept asking for my GMX password and would not accept them. I tried login on the web and it worked fine. I then removed the accounts and readded them but when I tried to set up the first account it didn't accept the password. I had to enter the password again and retry creating the account before it accepted it. 

This wretched problem is still ongoing.  I am with Virgin Media, and using the app passwords generated in My Virgin Media for Thunderbird.  Thus I'm unsure whether this is a Thunderbird or a Virgin Media problem (or a bit of both), My main Blueyonder account makes repeated requests for an IMAP password, but rejects them each time.  Nevertheless, the account is successfully sending and receiving emails (if I can get emails typed in between the "paralysing" demands for password).  If I generate a new app password in My Virgin Media, things seem to work normally for a while, but soon revert to the old "enter your passsword" game.

I also have the symptom that sent emails, while sending OK, are not being recorded in the "Sent" folder.  I've read somewhere that the Sent folder is fed back via the imap 'mail receive' function, but can't find much info. on that.

Anyone have any further experience on all this?

To be clear, you're using a password randomizer?

Not sure whata password randomiser is.  I'm using the app password generated in My Virgin Media - these are four words separated by hyphens, and used by Virgin Media to connect to their old "orphaned" accounts, for example Blueyonder and NTLWorld accounts.  The passwords do seem to work in so far as the account sends and receives emails with them, but even though they are working they keep asking all the time for the password and then rejecting it.  Eventually, after a long time, the requests seem to stop. As I said, generatins a new app password in MVM seems to resolve issue, but only for a few hours or until I reboot computer.  It's all very random and unpredictable...

I haven't seen any

That's the thing, Virgin Media keeps generating new passwords Thunderbird keeps the last known passsword, so if the password keeps changing Thunderbird will ask for it because the one that's stored does not match the ones created anew.

But each time I generate a new app password in My Virgin Media I delete the old one from Thunderbird's stored passwords and enter the new one.  The new one never seems to be accepted for long, and then it starts asking for another one - even though I'm still able to send and receive.

Surely Thunderbird and/or Virgin Media must be aware that this is happening?

Ok, change the authentication method to OAuth2.

Then reenter the password.

On my Th/brd install, OAuth2 is a listed option for the imap server, but not an option for smtp server.  Is this normal?

Looking into this further, I'm picking up that Virgin Media email system does not support OAuth2.  Is that right?  Thunderbird is offering it as an option for imap server but not for smtp

Thunderbird has that option for both servers.

I have this Th/brd account on two computers.  For SMTP both computers only give the options - No authorisation, Normal password, Encrypted password, Kerberos/GSSAPI, and NTLM.

Am I missing something?

Thanks for your patience, Mizar

@B - This page was started concerning Tbird problems with Microsoft Outlook Email accounts and most of the discussion is specific to that. Since you're asking about Virgin Media, you probably should have opened a new question about Virgin Media Email to avoid confusing things, ... but I'll throw in my two cents anyway

I don't have a Virgin account, but I took a look at their help pages. Take a look at:
Under "How to setup emails on a device" you'll see their recommended settings for IMAP and SMTP. Assuming the information on that page is current (it's not dated), they don't look like they support Oauth for email. They're just using 'app passwords', like microsoft was for a time.

From what I've seen you write here I think you understand, but just to be clear: the 'app password' they generate for you is to be used only with your standalone email client (Tbird, etc.), NOT when you login to Virgin or their webmail website directly - for that you use your 'regular' Virgin password.

Review the server settings they recommend, and check to see if you are using those - correct any differences.
Note that where they say "SSL encryption", the TBird setting would be "SSL/TLS". Similarly where they say Authentication: Password, the TBird equivalent is "Normal Password"

You can see this info in a table in TBird. Look at the "Mail and News Accounts" table under Help/Troubleshooting Information. Click "Include account names" at the top of the page to make the table slightly easier to understand if you have multiple email accounts. You can't directly edit any information there, but if you spot something fishy, you can go back to account settings and try to fix it.

You say TBird sort of works, but keeps nagging you for a new password. I had a similar issue with my outlook account, and I THINK the problem was that TBIRD somehow had two sets of settings for password and/or protocol for that account (ie one for normal password AND one for Oauth with IMAP and/or SMTP), and maybe was trying to use them both, and getting messed up. I seemed to be OK with just dismissing the new password prompt (not giving it a new one), but as you've said, its pretty annoying.

Take a look at your saved password list. Sort it by username (click on the username header), and make sure you only have 2 Provider lines for each username. One for imap, and one for smtp. If you've got more than that, even if all the passwords look right, get rid of the extras. If you do delete anything, it might be a good idea to exit and restart TBird before going any further to make sure the changes are saved and used.

For me, I think I cleared up my issue with Outlook email by removing the account from TBird and starting over, but hopefully cleaning up the entries would be enough.

Well, I think that's about all the help I can provide. Since I don't have a Virgin account myself, I can't offer any firsthand experience with their specific issues or test things myself. Good Luck!

Thanks for your detailed and thoughtful reply, Richk.

I am at my wits’ end with this.  All my account settings are as specified by VM, including the app password.  A few days ago, the account seemed to have stabilised, and (after it had made a lot of IMAP password requests and me doing “retry” and re-entering password many times)  it did eventually accept the password again and was saving sent mails in the “Sent” folder.  I rebooted the computer several times during the days to make sure that it was holding, and it seemed OK. That night I allowed the computer to sleep rather than completely shutting down, and the account continued to work all of the following day (yesterday).  I thought I’d finally cracked it!

But, after shutting computer down overnight last night, I rebooted this morning, and the old problem was back – repeatedly requesting passwords, although most of that time it was continuing to show received emails (but not saving sent emails to “Sent”).

This all seems so random…  I have just deleted the account and generated a brand new app password (and yes, I did remove the old password from the Thunderbird “saved passwords”).  I’ve now  re-added the account to Th/brd with its new password, and it’s working OK again.  I’m waiting to see what happens next and if it lasts, but if anyone can offer enlightenment as to what’s going on it would be welcome.  I have the account on two separate computers, and same symptoms on both.  With separate Windows and Thunderbird installations, that makes me think it must be a problem with the account itself at VM's end.  Where can I get help to resolve this?

Four hours after putting in the new password and getting account working, the fault has reappeared - continual rejection of app password and no longer saving sent mails in "Sent" folder.

OK, so maybe you could try enabling logging of SMTP and hope that something in the logs gives a hint as to what's going wrong. But I wouldn't be too optimistic.

You'll want to set the "mailnews.smtp.loglevel" to "All" (case sensitive) in the config editor.
(more info about working with the config editor:

To access the Config Editor:
Click ≡ > Settings > General
Scroll down to the bottom and click [Config Editor]

Then in the search box type: mailnews.smtp.loglevel
click the pencil on the right to edit, then type in: All, and hit enter.
(later when you want to undo this, come back to this same spot and hit the left leaning arrow instead of the pencil to reset the value.)

Then do a ctrl-shift-j to bring up the Error Console. Make sure the [Debug] button near the top of the window is selected. You can probably un-select the rest of them. You might also want to click the gear icon and enable "show timestamps"

Now send a test email from the problem email account to one of your other email accounts (so you dont have to bother anyone else with your debugging)

Take a look at the Error console and see what it says. Maybe there will be something there that points out whats wrong and gives you an idea about how to fix it. But more realistically, it'll probably just say something like "authentication failure" which isn't too helpful.

I'd suggest comparing what you see in the logs for failures and successes in sending emails so you can possibly isolate whats different when there's a failure. For success examples ideally you'd look at the logs using this account when its working. Otherwise, you could compare to logs of successful sends using other email accounts that are always working, but be aware that your other accounts might be using different authentication methods or have different quirks.

A hint about reading the logs. Some lines begin with a C: or S: Those stand for Client and Server respectively. Client being your machine, and Server being the Mailserver you're trying to talk to.

Unfortunately the logs 'suppress' authentication details, which I presume means passwords, so you wont be able to see exactly which password its trying to use. There may be some way to disable the suppression, but I haven't found it.

Since my last post the account has started working again -both accepting password and saving to send - though I'd done nothing to it.  When it started working again on main computer, the other one also updated without being touched.  Then an hour later got an IMAP log-in failure message on screen, and the other computer also had this.  However emails were still being sent and received, but not shown in "Sent".

Thanks for your logging suggestions, but I'm no techy and wouldn't understand the reports even if I managed to get them.  I have the feeling that I should be hounding VM to sort out this random-behaviour mess, since they should have the techniques and know-how.  Mind you, getting any response from them will probably take a week!

I'm very grateful for your comments.

Happy to help and I hope your problem gets fixed in the future.


About mailnews.smtp.loglevel
For illustration purposes take a look screenshots

Otherwise, and for my part, i don't use two-step verification, app password.

IMAP checked e-mail received ok sent ok 993 SSL/TLS Mot de passe normal 587 STARTTLS Mot de passe normal

POP checked e-mail received ok sent ok 995 SSL/TLS Mot de passe normal 587 STARTTLS Mot de passe normal

The OAuth2 fix is specific for Outlook.

Making moves

Well, some time has passed and I'm still having exactly the same problem.  Virgin Media put me in touch with their Gadget Rescue people, and they "took over" my computer and tried reinstalling the accounts with new app passwords, and then completely reinstalling Thunderbird completely.  If anything, this has made things even worse.  Admittedly, their operative was almost impossible to understand through thickly accented English (not his fault, they just have the wrong people doing these jobs).  Since I'm having the same problem on two separate computers (so two Thbrd installations and two Windows installations), I'm wondering just where the root of the problem is - is it Virgin Media or is it Thunderbird.  Meanwhile, my Android mobile seems to be working OK with the same account settings.  Today, one of the accounts hadn't received any of today's received emails (all showing on my Android) when I booted computer at mid-day - in fact latest emails shown were from day before yesterday.  The account was still sending emails.  Then, in the early evening all of the missing emails suddenly arrived without any action from me.  All of the time I'm getting the message "Log-in to server with username  failed" even when it is successfuly sending messages (but not saving in the "Sent" folder.

Could this be a corrupted Thunderbird profile problem?  If so, why is it happening on two computers?  

I'm at my wit's end with all this - four weeks now, and I'm still not sure whether it's a VM or a Thunderbird problem, or why my Android isn't affected.

One question, did the Gadget Rescue people "take over" both of your computers or just one?

No, they only took-over my normal/main computer.  The other one is kept as a backup for desperate times like these.  The other one was, however running at the time and connected to router's wi-fi.

Out of interest, I found this curl command line procedure from a google search.  I don't know whether it's of any meaning or relevance to the problem -

"C:\Users\xxxxx>curl -v smtps:// -u[xxxx.xxxx.xxxx.xxxx]

*   Trying

* Connected to ( port 465

* schannel: disabled automatic use of client certificate

* schannel: next InitializeSecurityContext failed: Unknown error (0x80092012) - The revocation function was unable to check revocation for the certificate.

* Closing connection

* schannel: shutting down SSL/TLS connection with port 465

curl: (35) schannel: next InitializeSecurityContext failed: Unknown error (0x80092012) - The revocation function was unable to check revocation for the certificate."

[The x's have been substituted for name and password]


I'm no expert but yeah it seems there's a lot going on there.

Ok, try this, change authentication to "normal password" let's see if that stops the security check from tripping.

The accounts are already using "Normal password" -  there isn't  an OAuth2 option listed for them.  Also, although that command-line output speaks of SSL/TLS on port 465, the smtp server is actually set for STARTTLS on 587.  But I don't know how the Curl command works, so that may not be relevant to anything. I'm not sure anyone understands what's going on here - I certainly don't.

This morning when I booted the accounts weren't showing any of my test emails after midnight-ish last night (although todays were showing on my phone).  Then about 2.30pm, emails arrived, and the accounts were sending and receiving normally again.  For how long, I'll have to wait and see.