Showing results for 
Show  only  | Search instead for 
Did you mean: 

Mozilla Thunderbird issues with Outlook Accounts

Familiar face

I'm not really sure if this is the right place to have this addressed but i'm having issues with Outlook email accounts in Mozilla Thunderbird.

Apparently is keeps on asking for the password even though it has been memorized.

The version number is

115.7.0 (64-bit)


Making moves

Same problem, just started a few days ago. Outlook pop imap are not accepted by Thunderbird anymore.

Microsoft activated a protection since the last virus attack on their server?

Making moves

Started to me as well since last Wednesday

Making moves

Plus one here... To be precise, it is happening since yesterday 2024-01-24, and with two hotmail accounts that I have configured in Thunderbird to be downloaded using POP. My setup has been working since years ago without modifications. 

Making moves

Same problem for me. No connection to Hotmail and Outlook. After I clicked away the message that the password was wrong four times (repeat), emails are fetched. But then the message comes up that the server is down. This is since update to 115.7.0 (64-Bit)



IMAP 993 SSL/TLS Mot de passe normal 587 STARTTLS Mot de passe normal
POP 995 SSL/TLS Mot de passe normal 587 STARTTLS Mot de passe normal

115.7.0 for my part checked yesterday and today at instants t that's ok1.png

Those are my settings and still the error pops up.

Making moves

Yes, it works now... Microsoft is freaking out about something... 😋

Making moves

Also same here, interestingly though I have 2 accounts which are no longer syncing but I also have an which IS still syncing fine.

All 3 accounts are configured using IMAP settings.

Making moves

It stop working again this morning.... 🙄

Something is afoot...

I have the same problem with Thunderbird, even when it is updated to the latest version.

Thunderbird seems to have changed the login process to Hotmail. They have changed the password option to "OAuth2" on all of my two Hotmail accounts.

The correct login option is "Normal Password", I had to change it back on both the SMTP and Server settings for both accounts.

Leaving it on "OAuth2"  leads to Outlook sayings login is disabled, due to the fact that you have not allowed your browser to receive or store cookies!

When I changed it back, I still get the error that the password has failed from Thunderbird, and a request to retry!


Familiar face

So, I've found the answer (hopefully...) changing authentication method to OAuth2 on both servers solves the issue.

You will be asked to reenter your password and allow account acess to Thunderbird but after that's done it will be happy sails. (hopefully...)

Making moves

Your solution worked for me, thanks!

Will be doing some testing, but so far seems to be working, thanks.

Created an account just to say that it works and to thank you 🙂

Making moves

It was still not working so I made the changes you propose, and it worked! Hopefully, it will last...

Making moves

Here's an update. Today went check e-mail and while I changed authentication method for OAuth2, client said server don't support current authentication method, so I changed it back to Normal Password and the old issue returned.

Be sure to check that you are using the current IMAP server, if you are still using the old it doesn't support OAuth2. I had to change it to and then set the OAuth2 as authentication method for it to work.

That as the missing piece of the puzzle, so you will need the OAuth2 and the for the new setting, now everything is back to normal. Thanks.

Making moves

I have had Oauth2 from the start and it still does not work.  Getting really frustrated. 

Between this issue and Unified Folders chocking and severely lagging unless I move most messages to Archive, and the super temperamental TBSync, I am just about ready to throw in the towel and go back to Outlook. Ever since I moved to Thunderbird, I have that feeling that my entire email and calendar set up is  like an old junker barely held together with duct tape and rubber cords that need constant attention to just barely function... 

Making moves

I've been seeing the failed login issue the last few days too. The simple answer for me was just to click the 'retry' button - after which everything was fine. But the problem returns the next time I restart TBird. So far just a minor inconvenience.

BUT... The problems here apparently are very dependent on whether your MS email account is a work/school account or personal one. As far as using OAuth2 goes, apparently that's now required by MS for work/school accounts, but not yet (?) supported for personal accounts (outlook/hotmail/365).

Since I have a personal account, I'm using 'Normal password' authentication for both IMAP and SMTP servers. I've told TBird to use SSL/TLS for IMAP, but can't get that to work for SMTP, so use STARTTLS there. I've got two-step verification enabled, so the password I use in TBird is an 'app password' (see the Microsoft link) Note that when you change at least some of these mail server settings in TBird, they don't take effect until you restart the program.

See the Mozilla support link for suggestions for different situations.


Familiar face

Interesting, mine is a personal account and OAuth2 worked, have you changed the servers to as @Carmeline and @Murkalael suggested?

Since the app password technique was working for me, I initially didn't work too hard trying to force OAuth2; but I am pretty sure I read notes from MS saying that OAuth wasn't supported yet for personal accounts, which agreed with some of the error messages I got when I tried it. Evidently those notes were out of date, as you've discovered, it IS now supported, and I did eventually get it working too.

I ended up going a different route than others here have used. I removed my existing outlook account from TBird, then added it back in. That wasn't 100% straitforward either, but wasn't TOO bad. Use the new Account Setup Wizard (for an existing email account) choose the default IMAP configuration (which agrees with what people here are suggesting), but hit the configure manually button. Then switch the IMAP and SMTP Authentication methods to OAuth2. Hit Done, and you'll get the normal oauth web dialog pop up where you log in to your Outlook account, and then everything's good to go.

You may have to tell TBird to allow cookies from the proper MS domain too, but I don't think I did this when I installed to my laptop, and it still worked - but maybe I'm mistaken about that.

Making moves

No matter what I do, I cannot get TB to accept my outlook account's credentials(3 of them). I am continually assaulted by TB to provide passwords. This seems to happen so often and it is becoming very grating to use TB, at this point I have to login to webmail to even see if I get e-mails.

Making moves

It seems to be an issue on Outlook's end.  Especially if you have 2 3rd party clients trying to read from your outlook account (like Thunderbird on your comp and other one on a mobile device).

Per Microsoft help site:

"You may receive a connection error if you configured your account as IMAP in multiple email clients. We’re working on a fix and will update this article when we have more information. For now, try the following workaround:"

I have tried logging in from mobile and it is not a problem, as long as the mobile is verified. I only use the browser, not a mail client.

I tried using OAth0 on a windows 10 machine and is does not work. It throws up errors saying your browser does not accept cookies, therefore your client is disabled!

My browser should not be involved.

Another tip when you get a password failure dialogue, is to press F5 (refresh), then you get the messages downloaded and you can press cancel on thunderbird's error message.

I have no problem logging into my mail using OWA method via the Opera Browser, so the problem is with Thunderbird. The OWA method means that you have to have multiple windows open for more than one account, which is why we use Thunderbird.

Mozilla connect have made several suggestions as to how this should be resolved.

But they have not yet admitted they know what the problem is in Thunderbird, that only occurred recently, without nay user changes.

Very frustrating when you have to fight your mail client everyday!

You wouldn't have a problem logging in on your phone through the browser, nor did I.  MS specifically stated if using "email clients", so not the browser.  I'm also betting that doesn't include the Outlook email client app.  But any other email apps would be included.  And since I had T-Bird and another one on my phone trying to read from it, that would make it "multiple clients" as they stated.

Deleted my accounts for my Outlook email from T-Bird and my phone yesterday then re-added them using OAuth instead of just password.  Haven't had the authenticate failure message yet.  But it was a bit intermittent for me.  Looking good so far though.

Making moves

Thankfully I've found this thread. Same problem as above but I've had to jig around some settings... here with '' being new (for me at any rate) as the server. But 'OAuth2' is also certainly part of the re-jig and it works. I was actually logged into my MS account while setting up Thunderbird for the godknows how many attempts (over the past few days). Like others, all I had been getting was password errors - unable to log in etc. Mobile phone access was fine as was logging in direct via a browser.

But today, on setting up Thunderbird I got another window open, which basically said allow Thunderbird access, message then came via the Microsoft Authenticator and, well I nearly fell off the chair. Finally things are happening again. Peace once again!

I have three screenshots, but Mozilla will only allow me to upload one at a time!

This one shows the error if it is set to OAthu2

This is my server settings for AOth2 which fail. For anyone asking if they are set to

This is my SMTP setting on OAuth2 which also fail.


Something to check if you haven't adjusted the settings, not the "account settings", the T-Bird settings -> Privacy & Security

Accept Cookies from Sites

Accept 3rd Party Cookies

Make sure that you are allowing cookies.  If you don't want 3rd party cookies (I have mine sent to Never), just be sure to as an exception and such so it will allow their cookies at least.

Thanks for the info.

I could tick the "Accept Cookies from Sites" in options/Privacy  & Security of Thunderbird, not account settings.

I also had to set an exclusion for "" which is Outlook.

Then I reset the login account settings to OAuth2 for SMTP and Server Settings.


Then I restarted Thunderbird.

Microsoft Outlook then insisted that I sign in using Microsoft's own login for each account, including the password.

Then I got a please agree form from Microsoft to accept Thunderbird as a app which can access my email etc.

Each Account had to be signed in separately.

I then had to wait for Microsoft to send an email and confirm that Thunderbird now had access to my data.

Mozilla really needs to update their Thunderbird support and user information with these details! and not try and impose it on users without telling them!

Making moves

Hi All,

Having same issue myself with syncing Hotmail accounts through TBird - currently using IMAP with connection security SSL/TLS and Normal Password.
Checked my cookie settings and they are set to accept.

Is there a verified solution to this? Do I need to change security settings? 

Edit: I just found this, so M$ acknowledge they're investigating the issue!


Change normal password to OAuth2.

Thanks, I will try that. 

I tried it, and got a Thunderbird message in the lower RH corner that the server does not support OAuth and to change my security choice.  So, I guess I get to try all of them possibly.  Or wait for M$ to solve the problem.  Swan2k posted a link to that.  I also notice that the change to a different address is indicated elsewhere.  I intend to keep investigating.  Thanks for the advice.

I did the OAuth2, but also had to change the address to, and the verification method to STARTTLS or something like that.  What is interesting, is that Rick said below,

Also, in Account Settings/Outgoing Server (SMTP), there's a table of all the SMTP servers. Make sure there's only one for I had found two, one of which still had 'normal password' for authentication method, which I didn't want any longer, since I only want to use OAuth2 for this email account.

This will be a problem, because then I have to choose sending with one or the other, and putting a "reply-to" in it.  Microsoft says they are having multiple imap connections problems right now, and "are working on it".