cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Firefox scrolling jumps in Facebook

zdvaz
Making moves

When scrolling posts on Facebook, there are random jumps up to 6 new posts forward. It is necessary to scroll back and look for the last displayed post (photo, video, txt). It looks like firefox doesn't remember the last displayed position before updating the cache. It is very annoying because there is always a flicker.

391 REPLIES 391

Still jumps for me, too, with Firefox 111.0.1 (latest version) and Windows 10 Pro. 

Bunk. I've been using "Most recent" for many years, and it's been jumping for well over a year, possibly two.

Sorry. Spoke too soon. As in the past when it seemed to be OK, after a day or two it reverted to jumping multiple posts. So now I'm wondering what the new format is all about.

gpiper
Making moves

FB Scroll-jumps for me so often I'm spending half of my time scrolling back up to see content it "tries" to make me skip.

1artworkz
Making moves

Why hasn't Firefox fixed this annoying bug? It doesn't happen in Google Chrome.

slizgi
Making moves

This bug is known for years, sometimes it goes away for a while, and suddenly appear from thin air with double the power 🙂 Latest FF and W10. Maybe fb container causing it?

I don't think it's necessarily all FB.  I'm using both FF and Safari on a mac and it doesn't happen to much when using Safari and when it does it only jumps about one post instead of the 6-7 posts that happens when I am using FF.  So???????

GButch
Making moves

I'm about ready to make the move to MS Edge.  When will the jumpy scrolling on Facebook get straightened out?  It has been much too long.  I don't really care whose problem it is.  Find a solution and fix it.  I prefer Firefox, but using it on Facebook is maddening. 

Galliwampus
Making moves

Late to this party, but rather annoyed to learn that this is an ongoing issue, and appears not to happen on other browsers. FF, you're my browser of choice; please don't make me/us change to another. The first thing I check after each update is whether this skipping issue has been resolved.

 

Does not happen to me anymore. New Computer, Windows 11 and Edge. Goodbye FF

Scarp825
Making moves

Getting used to Edge wasn't that difficult!!

Nifo
Making moves

Im giving up.

Nifo
Making moves

Oh, the latest versions of Edge is actually really something. Was like going from a limping elephant to a fast cheetah! Super smooth scrolling as well!!

martinr
Making moves

yeah I gave up & switched to Edge a while ago .. honestly don't regret it a bit

brokentoy
Making moves

back again even worse on latest update

 

GButch
Making moves

We have now been dealing with the jumpy Facebook scrolling for more than a year.  There is obviously some issue between FB and FF.  There are a number of reasons why I prefer the FF interface to Edge, so it remains my default browser.  But I do my early morning FB feed visit with Edge.  That's  absurd.  Why, after all this time is there no work around? Why isn't fixing this a priority?  🙄 

I complained about this issue earlier in the year. A couple of weeks ago I scrolled all the way back to the beginning of this thread and found a post by jscher2000 on 07-25-2022 10:21 PM.

I used his suggestion and it fixed the jumpy issue in Facebook for me.

Here it is in a nutshell.

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

Please keep in mind that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(B) In the search box in the page, type or paste layout.css.scroll-anchoring.enabled and pause while the list is filtered

(C) Double-click the preference to switch the value from true to false.

(D) Restart Firefox.

Can changing this setting mess up other websites?  I have been afraid to change it, but this issue has been going on for WAY too long!

1artworkz
Making moves

It didn't for me. If it does for you, you can go back and reset to TRUE.

Survivor_CZ
Making moves

I have same problem auto-scrolling FB. FF version 115.0.2

ed_oliveira
Making moves

facebook and instagram - still happening, good thing is that it disrupts my doomscrolling, but unfortunately other people i recommended firefox falled back to chrome because of it

brokentoy
Making moves

another update and another backward step and the doom jump scroll is back, honestly how do these people hold down jobs

 

readymatrimony
Making moves

I am having this issue in Many of Matrimonial websites i am Browsing no matter its shaadi.com or jeevansaathi.com

 

 

The best Matrimonial Script in India

even I am facing same issues 

for https://indiamachinemart.in/

India;s B2B industrial Marketplace

moffc
Making moves

I'm seeing this too. It stopped for a while, but Firefox has just updated and it's back.

Yep, it back again.

Facebook needs to get their head out of their a$$ and work with the browser companies.

 

 

It's worse than ever AGAIN. Seems like Facebook just doesn't care, & Mozilla can't keep up with the constant changes Facebook is making. Would be nice if the 2 would have a discussion to end this year-long back-and-forth crap.

At this point it appears we have reached an impasse!

This ridiculous set of erratic behaviors has gone on for a year now, bouncing up and down like a roller coaster, with no real progress, 1 step forward-2 steps back, recently back again and worse than ever; and neither Mozilla or Meta cares to even comment!

DX3M
Making moves

been going on for years, without resolve.. now it's happening after like a few scrolls already...

gpiper
Making moves

Running Firefox 116.0.3 (64-bit) Mac it will often jump down scrolling in FB even while I am scrolling UP!

IvanFlack
Making moves

Still not working in 116...you would think by now that the "experts" would have sorted this out! Bloody rubbish is what it is! I used to be a real fan of FF now it looks like I am going to have to use a worse browser like Google that at least works!

 

Did you try this?

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

Please keep in mind that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(B) In the search box in the page, type or paste layout.css.scroll-anchoring.enabled and pause while the list is filtered

(C) Double-click the preference to switch the value from true to false.

(D) Restart Firefox.

Thanks for the info and your help, however, this fix is among many tried. Some work for a little while before the behavior returns, others don't work at all depending on affected systems.  Also, this issue shows up on other browsers on some systems (including mine), leading me to believe the problem lies mostly with Facebook.

I resisted making the change in about:config until a month or so ago, but it has worked for me and I no longer have the issue.  I haven't noticed that the change had any negative affects on other websites, either, which was my concern and why I resisted changing the setting.  Sometimes Facebook does other weird things after I've scrolled for awhile; I think it's due to some kind of buffer filling up.  But at least I can scroll through the feed again!

"I resisted making the change in about:config until a month or so ago, but it has worked for me and I no longer have the issue."
Like-wise, however I also use the reactions other than like a lot; while Fb is loading the reactions, I often also pre-load a lot of the rest of the page, which seems to contribute to no spastic scrolling.

dera1987
Making moves

same scrolling issue on YouTube and Instagram. Basically all social media platforms

 

ajp1228
Familiar face

Mine had been doing a lot better recently.  Tonight the issue is back with a vengeance!   I see that my Firefox browser had installed an update yesterday morning (8/30).  I wonder if this has something to do with the update.  If so, it SHOULD have shown up last night when I was on Facebook, but I wasn't on there as much yesterday so perhaps I just hadn't scrolled enough.

I'm now going to try the "about:config" change in the post above.  I hope it doesn't mess up something on other sites.  This original topic was posted a year ago, and it seems to me that the issue is even older than that!  This is ridiculous!

If you have a problem, you can undo the change by reversing the change.

IF I can find my way back here and remember what I did.  LOL

Hey, it seems to be working better so far - no jumping when scrolling.  However, after I scroll so far I've been getting this: 

ajp1228_0-1693604176280.png

Is it normal for it to stop loading posts after so long.  I didn't think I had been scrolling all that long, but it's happened twice this afternoon.  I have seen this in the past on rare occasions, so it could just be a Facebook glitch today.

 

To undo the change, you can simply go back to change  layout.css.scroll-anchoring.enabled from False back to True. As far as your error message, I have never experienced that issue so I can't provide a solution.