Showing results for 
Show  only  | Search instead for 
Did you mean: 

firefox not working on intel Sonoma machines at all, even beta dont work for weeks now

Making moves

after update to sonoma, firefox just dont work, this problem happened to a lot of people but no fix until now 

i tried sonoma beta, firefox beta all dont work no add ones or anything


i hope you can fix it 

sonoma 14.1


Making moves

I have the same problem since upgrading to Sonoma.

Making moves

Just updated to Sonoma (14.1.2 (23B92)), and I'm also experiencing problems with Firefox (120.0.1) on an Intel-based MBP (2.3 GHz Quad-Core Intel Core i7, 2020). Firefox does work, but tabs regularly get stuck on opening. If I wait long enough I get an NS_ERROR_FAILURE error when I look into the network debug console. Strangely, this is intermittent (the same site will work once, and then hangs the next), and loading the site in Safari (sic) usually gets Firefox unstuck when I reload the hung tab. I suspect some name space resolution issue, possibly with some caching involved within MacOS. I've tried to activate http logging inside Firefox while the problem was occurring, but I cannot make sense of the trace I got (NS_ERROR_FAILURE does not even appear in the log file).