Showing results for 
Show  only  | Search instead for 
Did you mean: 

Firefox Daily Unresponsiveness

Making moves

I've used Firefox as my main browser for donky's years, but I'm getting tired of this new behaviour.

Every single day, I find my running browser incidence fails to connect. it looks like it's working, but new searches or addresses entered will do nothing. It's like I'm editing a screenshot!
So I have to close it and start anew. Daily.
I leave it running, incidentally, because I have lots of tabs doing various things, and dont want to have to go back through this loop every time, but it seems I must (or just use Edge Chrome and be normal, I guess).

As if this wasn't bad enough, there are perpetual updates, which generally result in security.enterprise_roots.enabled being set to false, so I have to edit that too.

I've also had to add -allow-downgrade to my shortcut, because It was forcing me to create a new profile on a daily basis.

Maybe it's a Windows thing, or maybe it's a firewall or A/V thing, but whatever it is, it's unsustainable and tiring for me as a user. Sorry


Familiar face

That isn't normal for sure!

I would to clean every profile and maybe even reinstall.

I assume you have tried to restart it with add-ons disabled, to exclude the possibility of one causing the issues you're facing.

if you go to: about:profiles

There is a button on the top right to do just that.

There is something you can do to force your preference "security.enterprise_roots.enabled" to false.

If you are comfortable with files, you can go to your profile folder, the "root" one, where there are a bunch of folders and files.

The path is similar to this:


or you can press the button in about:profiles that corresponds with "Root Directory"

and there you can place a file named: user.js

Inside you will put the lines you want to override, so as an example you can have lines like this:

user_pref("", true);
user_pref("", 0);
user_pref("browser.eme.ui.firstContentShown", true);
user_pref("browser.formfill.enable", false);
user_pref("browser.launcherProcess.enabled", true);

Then that should override the prefs.js so you never have to change that again.

"...because It was forcing me to create a new profile on a daily basis."

That is definitely not supposed to happen, can you check the profiles folder?

Can you check it is not being deleted, for example?

Also, if you go up in the folder tree, there is the file "profiles.ini"

It should be pointing to the profile, if that is messed up, firefox will not know where the profile is.. so you get the point.

I think i gave you a bit of stuff to digest, let me know what you found out.

Thanks @Boobieta, this looks like great advice!
I found that I had a whole load of redundant old profiles, so zipped them all up (just in case) and removed all but the currently active one.
I added the user file too, so hopefully that issue is at least dealt with forever!

It's actually been behaving itself this week, so I'll wait until it plays up again, and try restarting with add-ons disabled, to see if it helps.
I only have a few add-ons, but it's certainly worth a shot.
It's just unfortunate that this always happens at the most inopportune moment, so i just use a different browser instead, to get whatever it is done.

My next thoughts are that it's related to a recent change in our AV supplier, as this only happens on my work PC

Thanks for the advice


As of version 49, Firefox can be configured to automatically search for and import CAs that have been added to the Windows certificate store by a user or administrator

What antivirus software do you use?

If using the Windows certificate store
security.enterprise_roots.enabled true

If using the Mozilla certificate store
security.enterprise_roots.enabled false
Illustration using the Mozilla certificate store
Other illustration

Thanks @Agentvirtuel 
We use the Microsoft Certificat Store, but one issue is (was hopefully) that security.enterprise_roots.enabled has been reverting to FALSE.

We've had a few different AV solutions due to commercial agreements, but the last one was an absolute disaster, so We're currently on good old MS Defender, but there have been issue with some of the rules applied by out IT admin.



@russbroom wrote:

We use the Microsoft Certificat Store, but one issue is (was hopefully) that security.enterprise_roots.enabled has been reverting to FALSE.

Try Registry Editor

A test creation of register keys ImportEnterpriseRoots

Please, right-click in the screenshot, open screenshot in new tab, then click in the screenshot, thank you

Another possibility for creation in

Use the Troubleshooting Information page to help fix Firefox issues

Enterprise Policies: This shows you if your browser is being managed by Windows Group Policy or a policies.json file. If enterprise policies are managing Firefox, clicking on Active will show you a list of the policies that are currently active on Firefox.

Familiar face

Started to have issues with this exact same issue, on mobile beta, the certificate was not being accepted, when i checked in about:config, there it was: security.enterprise_roots.enabled = False

When before it was True, so then i investigated further and the conclusion was this: it didn't matter how many times i changed about:config, the only way to make it persistent and stick in "True" was by going in the hidden settings menu and enabling the feature for the certificates. You go into this hidden menu by pressing a couple times in the firefox logo in the about interface. Doesn't apply in desktop version.