Showing results for 
Show  only  | Search instead for 
Did you mean: 

Automatic Translation in Firefox makes it unusable

Making moves

Dear all,

I am more than annoyed by the automatic translation feature of the Firefox browser that cannot be controlled. I live in Germany and added English text to a Jupyter Notebook Markdown cell and it was against my will translated to German. I had to set the browser language to English and restart it. The most unacceptable thing is that my surname, which is Class, was translated to Klasse. A until now excellent browser is about to become useless!

I have been a loyal user of the Firefox Browser for many many years now but if we cannot get back control over the languages we want to see and use (there are people who are multilingual), I will consider changing to another browser.

Such features should be switched on by the user on purpose but never automatically.

Please give us back control!




Hi @cbc, thanks for reporting this!

I'm one of the developers for Firefox's Translation feature and I'd like to try to help if I can.

Firstly, I want to try to clarify what you mean when you say that the automatic translation feature cannot be controlled.

We do try to offer a couple ways to control this functionality:

From the settings menu of the Full-Page Translations Panel (as shown in the article section linked above), you should see an option for "Always translate {language}," which will either be checked or unchecked based on the determined language language of the current page that you are on.

You mentioned, "such features should be switched on by the user on purpose but never automatically," which I assure you is our intent as well. We do not intend to enable auto-translate by default for any users, but we do persist these settings between sessions if the Firefox user has enabled auto-translate for a particular language on their profile at an earlier time.

It sounds like your browser may have had auto-translate enabled for the determined language of your Jupyter Notebook page, whether due to an unintended bug, or due to that option being set at an earlier time and persisted to this session. At this time, I am not aware of any bugs that would cause this setting to be populated unintentionally, though if such a bug exists I would like to resolve it promptly.

As a definitive check, you can type about:config into the URL bar, and search for the preference called browser.translations.alwaysTranslateLanguages to see if you have any language tags listed for that preference.

As a secondary level of control, you should be able to navigate to the settings menu of the Full-Page Translations Panel (as shown in the article section linked above) and enable the "Never translate this site" option for the page that you're on. This setting should be respected on a site-by-site basis, even if you have auto-translate enabled for that site's determined language.

Finally, I want to address that you mentioned your surname was translated from Class to Klasse. Each translation language pair consists of one or more custom-trained machine-learning models that run privately within the browser. While statistical models like this will never be 100% perfect when applied to an infinite number of specific contexts, we are working hard to both train more models to support new language pairs as well as improve the quality of existing models for language pairs that we already support. This includes improving the accuracy of recognizing proper nouns that should remain unaltered in translation, as well as a number of other categories such as grammar, punctuation, capitalization, numeracy, etc. I'm sorry that the current model translated your name incorrectly (or at all, for that matter) in the given context, and I hope that a future model release will improve on this aspect of translation quality.

Please let me know if you have any further questions, concerns, or requests for clarification. I'm happy to help.