Showing results for 
Show  only  | Search instead for 
Did you mean: 

What happened with text font size in Thunderbird 115.3.0?

Making moves

I've been using Thunderbird for years, but the latest update is terrible! The message list is almost unreadable, and there's no way to change the font, or at least increase the reading size of the list!. Space between lines is non existing, Font size is small, no zoom option... overall, your worst update ever! After this update, and if nothing changes very quickly, I definitely will opt for other email client than yours.


Making moves

I agree, even with the change in density / font size. I believe the contrasts/color/fonts have been changed (To be more "smooth" ?) and after only half an hour, I have an headache trying to focus on the screen


Making moves

the new version is terrible indeed. how can one fook up that badly with a perfectly fine design? it is beyond my imagination.


Take a look New Density Options/choices in 115.4.3 are terrible

Try userChrome.css


/* ---How to restore pre-supernova display density-- */
:root {
--list-item-min-height: 20px !important;
--list-item-buttons-size: 20px !important;
/* ---Message list spacing-- */
tr[is="thread-row"] {
height: 5px !important;
/* ---Height of the inbox list view-- */
#threadPane {
min-height: 110px !important; /* default 200px */


Copy/paste the code (for example) into Notepad
Type: All files

Create a chrome folder
Move userChrome.css to your chrome folder

Go to your profile folder Open Folder

Move your chrome folder to your profile folder

Go to Configuration Editor

Alternatively in the Settings tab, enter about:config in the search box
The result is, Configuration Editor...1.png

Click on Configuration Editor...
The Advanced Preferences tab will open.

Search for a preference name toolkit.legacyUserProfileCustomizations.stylesheets
To edit a boolean preference (true/false value), click on the Toggle button to set its value to true

Stop Thunderbird start Thunderbird

Making moves

and there's no way to change the font

I keep finding people saying things like that and I have no idea why.

The Supernova 115* has more user friendly methods to control the Font Size than ever before.

On 'Menu Bar' toobar - View > Font Size > increase font size/decrease font size

On 'Unified Toolbar' use the 3 line 'Menu app' icon - click on it to see 'Font size' - you do not even need to locate it - it's on the opening menu list - where it tells you the currently used size in pixels and offers + and - icons to increase/decrease the font size.

The 'View' > 'Density' controls the space in between items and there are 3 options.

The Message Pane itself if using same default size can alos be influenced by the same Font Size controls, BUT people tend to put html code into emails in an attempt to control the design. In Thunderbird this can also be very much controlled and often people like this area a little larger in font size than used elsewhere.

Some people just use the Zoom - let's be very clear on this - Zoom only effects the Message Pane - the contents of an opened email - Zoom does not effect other areas like 'Folder Pane'.

However, if you end up using the Zoom a lot then it means you should set up something more suitable to prevent all that unnecessary zooming.

  • Settings > General
  • scroll to 'Language & Appearance'
  • click on 'Advanced'
  • Select 'Fonts for:' and choose 'Latin'
  • Set all Font Size a bit larger than you are using for the Folder Pane & Thread Pane eg: 16px
  • Set the 'minimum size' a bit smaller, so it stops people from forcing tiny font eg: 12px
  • Then select 'Font For:' and choose 'Other Writing Systems' (bottom of list)
  • set identical font sizes as the 'Latin'.
  • If you want more control over fonts then uncheck 'Allow messages to use other fonts'
  • Click on OK

The above sets up settings for both western and unicode, so do make sure you set up for both 'Latin' and 'Other Writing Systems' and indeed any other language format you use eg: Cyrillic


Making moves

2 computers here with the same Thunderbird version (115.5.1), and on one everything works fine when managing font size, and on the other one it is a mess.

The main difference is for the one having issues the screen size is 3440x1440, when the other one is only 1920x1080.

Could it be related?

Yes.  Screen size 3440 x 1440.  Is this one of those ultra wide screen monitors? Some MAC computers run those pixel sizes and often are using something they call duel retina or scale of eg: 125%  basically a type of zoom, so it renders a sharper image.  Thunderbird uses pixels for font size not points. So on each screen a 'pixel' will be a certain size. It means a 12px on one screen can look larger than on the other, due to individual pixel size.

You may also discover the font choice in 'Language & Appearance' settings can effect the general UI font size controls. It generally is not an issue, but in a particular MAC in another Support forum I've been trying to find out why inceasing Font Size does not effect eg: Folder Pane and it looks like there is a setting in Languages & Appearance which seems to block the font size.


Making moves

The compose text is too tiny regardless of font or text size you choose. I have to choose HUGE for it to look like medium. But when I send it, the recipient receives it as huge. TB 115.5.1 has become virtually unusable for me at this stage. Will try to find backup of a pre-100 version and set it to never, ever update.

In 'Settings > Composition'

You should select: Variable Font and Size Medium so that it always renders as whatever the recipient uses as 'medium'.  

But when it comes to you composing messages, the 'Medium' is determined by whatever you have set up as medium in 'Settings > General > Language & Appearance > Advanced'.

The 'Proportional - Sans Serif - Size: eg: 16 = medium for you.

But you must set up 'Fonts for' 'Latin' and ''Other Writing Systems' because 'Latin deal with western encoding and 'Other Writing Systems' deals with unicode encoding'.

The advise I have previously offered basically tells people what they need to check. However, people seems to mess up all sorts of things and it all goes out of ballance. Many times people set minimum sizes which are so large they override all their normal settings.

I cannot offer advise on what to do specifically in your case until you state exactly what settings you are using.  In Help > Troubleshooting Information, scroll down to 'Important Modified Preferences' and look for lines that start with 'font.' Copy all those 'font' lines and paste it into a comment, then I'll know what you are using.

Am using the latest portable version of TB. Odd thing is that it works perfectly fine on another computer (windows 10, 2560x1440p display). On main PC (4k display) and dual booting Win 10 and 11,  text, view is large in Win 11 but tiny on Win 10, esp when composing.

Am thinking nothing wrong with TB itself, just odd scaling behavior on high res displays.

Making moves

i would like to share with the dev a small bug in thunderbird about shortcuts in mail window.

so, every time i read my mail it is impossible to use the zoom shortcuts CTRL-/+  the directly.

i must first to play with the size font icone and after that i can use the shortcuts to zoom in the the mail.

It's really painfull because thunderbird has a bad managment font size in raw text: regardless of the settings i can use, the raw text font size are always small.

this bug is still there even after an update version or a OS changing (manjaro-ubuntu)

Version: thunderbird 115.7.0

OS: endeavoursos (archlinux)