cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Translate This Page beta: make it stop!

carswell
Making moves

Today's update added a Translate This Page (beta) icon to the search box. There appears to be no easy way to disable it and the little tinkering I did in about:config had no effect.

First, what's the idea of adding -- and taking up toolbar real estate -- an unremovable function I didn't ask for and will use infrequently if at all? Second -- and this really gets my goat -- not only do I have the unwanted icon in my search box, a drop-down dialogue box appears whenever I visit a non-English page. And as a polyglot translator living in Quebec, I visit many sites a day that are in languages other than English. Yes, the box will disappear if I click the Cancel button or anywhere on the page but that doesn't make it any less obtrusive and significantly increases the amount of clicking I have to do (hello, carpal tunnel syndrome!).

This is unacceptable and if it's not fixed soon, I, a devoted Firefox user since the earliest days, will be ditching the browser on all my devices for good.

12 REPLIES 12

BrianHojmark
Making moves

Im with you. Please stop this annoying nonsens

cdnhermit
Making moves

How do I stop this beta page translation pop up that appears on every new page?  There is a need to offer a way to deactivated it.  Thanks

cdnhermit_0-1696342352358.png

 

yes, but keep show the button in the address bar, still there but, without action. I want to remove it.

Breizh
Making moves

Untick the first option ("Toujours proposer de traduire" here in french) , it will stop asking. But I didn’t try to disable it entirely, since I’m using it.

cdnhermit
Making moves

The Solution:

Open an about:config page and type the word 'translations' in the search field.

Then look for browser.translations.automaticallyPopup and put it to false. It will stop.

God bless you

Thank you!!! 😻

You made my day!

Maragatero
Making moves

Yes!! Please Mozilla, stop it!!!

 

Mizar
Familiar face

How to really kill off translations:

At about:config set the following

browser.translations.automaticallyPopup to false

browser.translations.enable to false

browser.translations.panelShown to false