Showing results for 
Show  only  | Search instead for 
Did you mean: 

SSO issue since upgraded to v118.0.1

Making moves


We have company internal applications that we run through Firefox since years. For the user authentication we use kerberos.

Everything worked well until we upgraded to v118. Most applications run on port 80/443 and the user can be authenticated correctly via GSSAPI and Kerberos.

But one application React gets its frontend code on port 3000 (html, js, ...), and this frontend calls APIs on port 5000 of the server, and that one does not work any more. The login page (returned from port 3000) allows us to logon via a user/password or via SSO. When we click SSO it opens a connection to port 5000 and calls "GET /sso_login", the server returns "HTTP/1.1 401 UNAUTHORIZED" and "WWW-Authenticate: Negotiate" to ask the client to authenticate.

On v117 the client sends back the same "Get /sso_login" but with this time with the negotiation token, and the server accepts it with a "HTTP/1.1 OK".

On v118 the client stops the communication after the "HTTP/1.1 401 UNAUTHORIZED".

I'm wondering what could have changed between v117 and v118 to make the authentication of that application to suddenly fail. Is it related to the fact the origin varies (port 3000 calls port 5000)? What can I do to solve the problem?

Thank you for any help,



Making moves


We are having a similar problem. Since upgrading to v118, our request to a cross-origin API responds with the correct CORS headers - namely origin and authorization - and with the code 401 UNAUTHORIZED. Previously this has triggered a basic authentication prompt as expected, but this is no longer the case. With v118, the communication stops with the response, instead of continuing to the authorization.

We tested with v117 and other browsers and all of them authenticated and handled the response correctly.

The release notes do not mention anything that should affect this behavior, so this might be a bug.

Hopefully this is addressed quickly, and thank you in advance.

- Patrik

Hi Patrick,

The only fix provided in v118 that I see could be related is this one:

But I don't know how to report this... Do I have to create an account on bugzilla as well?



Hi Patrick,

The problem was "magically" solved with the upgrade to v118.0.2 today...



Hi Pierre,

Thanks for the update, glad to see it resolved.

- Patrik