Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't download pdf files since upgrade tp 109.01

Making moves

Since doing the latest upgrade, all pdf downloads have failed.  The only solution that bI have so far is to use Edge for those.  Very inconvenient.



What happens when you try to download a PDF -- does Firefox display any error message that might help identify what is going wrong?

I don't know whether it will make any difference, but you could try switching your download action for PDFs to "Always Ask" or "Save File", etc., and see whether that has any effect. See:

Making moves

Thanks for the tips.  I had tried most of them, and it didn't help.  However, I did change the settings to "open in Firefox" and was able to open them, then save to the computer.  So now it just takes 2 steps to do what used to take only 1.  Thanks for the improvement, Firefox.

I forgot to answer your question -- all I got was a "download failed" message.  My previous setting had been to "open with Foxit" and then I tried "download".  Both had the same result.

By default, when Firefox is downloading a PDF with the "Use [external application]" or "Save file" settings, it will use the folder next to "Save files to" on the Settings page. Is that still set to the Downloads folder, or have you customized it?

By default, when you save a PDF out of Firefox's built-in PDF viewer, it will start off by using the last folder selected for a download from the same site, or possibly the last download folder for any site. So this may or may not match what you have set on the Settings page under "Save files to."

Where I'm going with this is: I wonder whether Firefox lacks full privileges from the system to use the "Save files to" folder for some reason. ??

In case that is a transitory issue, if you haven't already since the update, please do a normal shutdown and restart of your system.


Making moves

I did do a reboot, but the problem remained.  The only change to the system was the Firefox upgrade, and the problem is confined to Firefox.  So, I am convinced they changed something, and probably will hear from other users about it.  Until they undo whatever they did on their end, there is nothing I can do.  For now, I have a workaround and can live with that.  This is one of the problems with Firefox, and the reason I have Edge as a backup for when Firefox just doesn't get the job done.

Familiar face

Also, right-clicking on a PDF you can click Open in a new tab and then download it manually, you right-click it again on the new tab and you should be able to download it.