cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unthread Option is not running as default on New Version - 115.4.1

Joandrewrm
Making moves

Hi everyone, I'm having issues with the new update 115.4.1 (64-bit). In the previous version, when I searched for an email, for example by the sender's email, I could see by default the entire unthreaded mail display on one page. Now, with the new version, the email appears collapsed and I have to go to view, then sort by, and choose unthreaded. I have to do this process every time I'm searching for something related to a specific email. How can I make it display unthreaded by default?
Thank you for the help.

1 REPLY 1

nick_theboatman
Making moves

I also got this several versions back. I found a write-up of how to fix it using what I reproduce below (I built this note 28-11-2022) - doesn't work, mind, because there was some doubt about whether 18 was the right parameter for "mailnews.default_sort_type" - and of course there is zero explanation anywhere of what this parameter means...)

Anyway since v. 115 not only is the default view broken (defaults to "threaded") but the local folders / inbox setting for threaded | unthreaded seems to be volatile and unpredictable. Having realised that the view had switched to threaded, switched it back, shut down, come back, I found that the view had changed back to "threaded". So changed it back to "unthreaded"....
then later on I watched it dynamically switch the view from "unthreaded" back to "threaded" as it was downloading messages. It looked like it was trying to match threads in real-time as the messages were coming down, found some thread numbers and so switched to threaded view to be helpful. Right.
Wrong.
Good grief... 

~~~
Edit - settings 

scroll down, click on "config editor" button
Edit "mailnews.default"
Set:
mailnews.default_news_sort_order 1 (ascending)
mailnews.default_news_sort_type 18 (sort on date)
mailnews.default_sort_order 1 (ascending)
mailnews.default_sort_type 18 (sort on date)