Showing results for 
Show  only  | Search instead for 
Did you mean: 

PDF handling - never open PDFs

Making moves

I never want to use Firefox to view a PDF.  Ever.  I always want them to save or ask me (to which I will answer "save")

I've set the settings, general, applications, PDF to "save file" and that worked perfectly for years.  Now I open a page like this:

and it opens the PDF.  I've tried going into about:config and setting pdfjs.disabled to true, but that doesn't seem to have helped.  How can I completely disable Firefox's PDF viewer?  A browser isn't a PDF viewer and a PDF viewer isn't a browser.




As far as I can tell, that link opens an HTML viewer showing a sequence of page images. Is the problem when you use the overlaid "Download" or "Download as PDF" links that you don't get the usual dialog, but instead you get the PDF opening in a new tab?

Thank you for looking at that.  The issue is the PDF opening in the new tab.

Hmm, that's strange. Does Firefox add the PDF to the Downloads list (the list that drops from the Downloads button) as usual, or is Firefox handling it as web content (i.e., like a web page)?

Making moves

same goes for Thunderbid IMO