cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Firefox scrolling jumps in Facebook

zdvaz
Making moves

When scrolling posts on Facebook, there are random jumps up to 6 new posts forward. It is necessary to scroll back and look for the last displayed post (photo, video, txt). It looks like firefox doesn't remember the last displayed position before updating the cache. It is very annoying because there is always a flicker.

387 REPLIES 387

KipA
Making moves

I have been having this problem. It happens on Youtube home page scrolling as well.

spoofy
Making moves

I have this problem too, after update to the last FF version.

 

epossum
Making moves

I also have this problem and it has been occurring for several days now. My solution is to open Facebook in a different browser. I hate this. Totally ruins the experience. I have had a few pages crash while on Amazon.com as well.

This needs to fixed, ASAP.

LittleGreyHorse
Making moves

Same issue, it's been going on for a while now.  Tried reinstalling and troubleshooting/safe mode.  Still happens but only on Firefox.

 

KipA
Making moves

Was on 102/Win 10. 103 is the same . .  😞

peewee007
Making moves

I'm having this problem on facebork also..It's driving me a bit goofy...Currently using version 102.0.1. I've tried to downgrade to an earlier version but firefox just gives me a message saying that my profile might get corrupted or somethin like that if I don't create a new one...spose I coulda created a blank profile and tested it *shrug*

pmshop
Making moves

Not fixed with ver 102.01

Even worse actually.

Tyras
Making moves

For me, it scrolls randomly up or down, even when i'm not touching keyboard or mouse.

HPDeskjet
Making moves

Same issue.  Turning Autoscroll or Smooth Scrolling of or on has no influence on the problem.  This irritation makes Facebook unusable in the current Beta build. 

suhauck
Making moves

Same problem for me. It's driving me crazy!

 

Jmanb13
Making moves

This happens to me as well. The problem happens when facebook dynamically loads more posts when you get near the bottom of the page. It appears that the firefox page scroll attempts to keep you at whatever % of the page you are currently on (example 90% to the bottom) rather than wherever on the page you currently are. When facebook loads more posts firefox drops you to 90% of the page again and then facebook loads more posts, then firefox puts you at 90% of the page again. It repeats until you do a very fast scroll up to get you away from the bottom of the page and stop facebook loading more posts.

It did NOT previously do this, so it was a change in a recent version of firefox. It does not happen in Chrome or Edge, only Firefox. I assume something was changed in scroll behavior recently.

Does not happen in Safari, but sound quality always an issue in Safari, so what to do?

 

wrong forum

It's happening to me today only on Safari where I have a fb account. Will see if Apple can help. I don't see any resolutions on this stream


@Jmanb13 wrote:

This happens to me as well. The problem happens when facebook dynamically loads more posts when you get near the bottom of the page. It appears that the firefox page scroll attempts to keep you at whatever % of the page you are currently on (example 90% to the bottom) rather than wherever on the page you currently are. When facebook loads more posts firefox drops you to 90% of the page again and then facebook loads more posts, then firefox puts you at 90% of the page again. It repeats until you do a very fast scroll up to get you away from the bottom of the page and stop facebook loading more posts.


Does it make any difference if you switch off scroll anchoring? Here's how you can test that:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. Please keep in mind that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(B) In the search box in the page, type or paste layout.css.scroll-anchoring.enabled and pause while the list is filtered

(C) Double-click the preference to switch the value from true to false

(That isn't a new feature, but maybe its behavior has changed somewhat.)

 

This does not fix the issue.


@Piesang wrote:

This does not fix the issue.


Thank you for checking.

I added a couple of steps to this.
1. Changed it to false, quit FF, relaunched FF and verified the behavior did not change.
2. Changed it to true, quit FF, relaunched and scrolled. Eventually, the autoscroll behavior reappeared, but it seemed to work OK for awhile. Admittedly, hard to be sure.

But this suggests the 101 or 102 update broke parameter-checking; the fix may be to check scroll-anchoring.enabled after loading new material, before re-enabling screen display. Just guessing.

Another thought: Maybe it happens at the first buffer-full event; instead of returning control to the user, it goes back for more, breaking buffer control. Just a guess.


@hmkabaker wrote:

I added a couple of steps to this.
1. Changed it to false, quit FF, relaunched FF and verified the behavior did not change.
2. Changed it to true, quit FF, relaunched and scrolled. Eventually, the autoscroll behavior reappeared, but it seemed to work OK for awhile. Admittedly, hard to be sure.

But this suggests the 101 or 102 update broke parameter-checking; the fix may be to check scroll-anchoring.enabled after loading new material, before re-enabling screen display. Just guessing.


Thank you for checking.

I've been having the same issue and thought it was a Facebook problem and reported it to them.  A friend had also posted about having the same issue, but I didn't think to ask what browser she was using.  I have not tried other browsers.  I've noticed that the farther down the feed I scroll, the worse the jumping is.  There was actually a day or two that I thought the problem seemed to not be as bad, but then it got even worse.  I'm sure it happens when Facebook loads more posts at the bottom of the feed.  I've not been on Facebook much today - yet - so I don't know what it's doing under FF 103.

worked with MacOS

 

It does not work.

That FIXED IT.  Thank you!!!

Have tested and for me turning off the setting _does_ seem to fix the issue. When I turn it back on it reappears.

Works for me, too. v 109.0, OS Ventura. However, it brings back the problem of viewing multiple images in a post. After clicking through several images i the post, the "X" close icon is broken. In first case, it was completely disabled, and disappeared upon reloading. In the second case,  the view returned to some unrelated post, maybe not in the feed, and lines of tiny  text appeared down the left side. Restoring scroll anchoring fixed the multi-image viewing and return to feed, but topic jumping returned.

I stumbled on this thread while trying to troubleshoot the same problem --driving me nuts for months-- and your fix worked. I really appreciate that people take the time to respond to queries in support forums --thanks! 

FF 109.0.1 64-bit Windows 10

I tried this with my default profile, and it didn't work.  But after toggling layout.css.scroll-anchoring.reselect-if-suboptimal as well as layout.css.scroll-anchoring.suppressions.enabled, it did seem to work.  I also tried in a new profile, changing just the setting you suggested, and it worked, consistently on/off, and after relaunching.  Perhaps it's something about these scroll anchoring settings becoming corrupted from a migration routine, since an existing profile seemed to need extra toggling that a new profile didn't?

It works!  I'm using Firefox 114.0.2 (64-bit).  I've been trying to find a fix for the longest time and now your solution fixed my scrolling issue with Facebook.  Thanks a million!

I, too, am using Firefox 114.0.2 (64-bit). and jscher2000's work around does not work for me.

WRONG, I was wrong in claiming that jscher2000 work around does not work.
It works you just have to restart Firefox in order for the change to become effective.

I can confirm this works in MacOS with most recent Firefox V114.0.2.  THANK YOU!!!!

 

Seems to have worked for me. Thanks.

RandyB
Making moves

So does anyone have a fix?

See jscher2000, 07-25-2022, 10:21, PM, but remember to restart Firefox for it to work.

 

epossum
Making moves

I believe this is a problem Firefox developers need to fix. I reported it formally a couple of weeks ago. It can't be that hard to fix so what's the holdup?

ajawamnet
Making moves

Yes - there is an issue with Firefox on sites like Facebook that do look-ahead buffering of the page. Once the buffer gets to a certain point it begins the wild-ass scrolling.  This needs fixed.  Hell, Firefox has issue with it's own forum doing silly page reloads.  Not cool... 

Same situation. Once i reach out a certain point in FB FF or FB itself likes to do some fast skipping and without touching the mouse nor anything! (Obviously we're talking about the PC version)

102.0.1 and it started happening early this week (Unlike some from the starting post)

It's probably not FF but FB but who knows. However HOPEFULLY THIS GETS SOLVED SOON....

hmkabaker
Familiar face

Me too in v 102.0.1 I reported this to FB, but now I see it happens in another site as well. The new material should be buffered instead of triggering the scroll.