cancel
Showing results for 
Search instead for 
Did you mean: 

Everything is downloaded since update 98.0.1

MiZu
Making moves

Any file is downloaded and saved (to my desktop) even though I have choosen "Ask everytime where to save"

Any file I choose "open with" (Acrobat) is opened, but downloaded and saved additionally (to my desktop).

How can I prevent this?

Thanks for your support

1 ACCEPTED SOLUTION

COOL-ER
Making moves

I suggest looking for the thread on "How to Stop Saving Downloaded Files Automatically" from a few days ago: 03/09/22 there is a solution. It worked for me and others. I'll quote the answer but you can look it up.

After a satisfying curse session I went elsewhere on the Interwebz and found the solution.

In about:config (Welcome to the Wild West) search for browser.download.improvements_to_download_panel and set the flag to false.

Now the old pop-up handler is restored.

View solution in original post

5 REPLIES 5

JohnWest
Making moves

I have the same issue.

Do the developers have no interest in what the users want?

Depending on the files being downloaded I may want to save files (To a location which I specify) but never to the base Download folder.
I may also want to process the file and discard it.


It is a pity the developers did not spend their time more usefully in fixing a long outstanding error: "Do this automatically for files like this", which many users would have found very useful.

If Firefox is no longer going to support this, it is time I moved on to a new browser which will support me in what I need rather than what some backroom developer thinks I need.

This change, introduced without any notification caused me confusion and a lot of wasted time working out what had gone wrong with my processes.

anonymous254
Making moves

Not really impressed by this functionality change either.  Some users found it helpful to have that visual confirmation as default, when clicking a file link on a webpage.  The non-ability to add a Content Type to the Applications window isn't stellar either.

alonisoft
Making moves

Since the update 98.01 our users do not understand why each opening of any type of file like pdf, msg, eml, mp3, tif, etc.....  offers to save instead of opening using a program defined for them in the browser like before.

Meantime, we found option to change it by update the handlers.json in "AppData\Mozilla\Firefox\Profiles".

also tried this: change-firefox-behavior-when-open-file but the msg/eml not open only save option...

considering to move to Portable version ...

COOL-ER
Making moves

I suggest looking for the thread on "How to Stop Saving Downloaded Files Automatically" from a few days ago: 03/09/22 there is a solution. It worked for me and others. I'll quote the answer but you can look it up.

After a satisfying curse session I went elsewhere on the Interwebz and found the solution.

In about:config (Welcome to the Wild West) search for browser.download.improvements_to_download_panel and set the flag to false.

Now the old pop-up handler is restored.

Thanks for posting this COOL-ER.  It helped.

It did restore the behavior, however the "Do this automatically for files like this from now on." checkbox was automatically checked / enabled. 

Just letting folks who may pass by know to uncheck that setting: if you want to keep seeing the pop-up handler for that particular content type.

Still on the fence whether I am going to switch back the (nn) profiles back over to Firefox that were changed at the office, due to this nonsense.